Closed Bug 1102344 Opened 5 years ago Closed 5 years ago

Call counts are displayed incorrectly in the call log

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect, P2)

defect

Tracking

(feature-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
2.2 S5 (6feb)
feature-b2g 2.2+
Tracking Status
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: drs, Assigned: thills)

References

Details

(Whiteboard: [planned-sprint c=1])

Attachments

(5 files)

Attached image Screenshot
Call counts in the call log are being broken up incorrectly in RTL mode in the call log. See attached screenshot.

Bug 1080828 should provide us with useful guidance here.
Target Milestone: --- → 2.2 S1 (5dec)
Assignee: nobody → drs.bugzilla
Whiteboard: [planned-sprint c=?] → [planned-sprint c=1]
Assignee: drs.bugzilla → thills
Hey Doug, is there is some work in progress here?
Flags: needinfo?(drs.bugzilla)
(In reply to Ahmed Nefzaoui [:Nefzaoui] from comment #1)
> Hey Doug, is there is some work in progress here?

Nope, feel free to take it.
Flags: needinfo?(drs.bugzilla)
RTL triage: P3 -- this bug is not prioritized for inclusion in the 2.2 release.
Priority: -- → P3
Target Milestone: 2.2 S1 (5dec) → 2.2 S5 (6feb)
Dylan, should this be "feature-b2g: 2.2"?
Flags: needinfo?(doliver)
See Also: → 1126850
(In reply to Doug Sherk (:drs) (use needinfo?) from comment #4)
> Dylan, should this be "feature-b2g: 2.2"?

Yes, probably. This was initially judged to be P3 but we've given higher priority to similar bugs liks bug 1125069, so let's bump this up.
feature-b2g: --- → 2.2+
Flags: needinfo?(doliver)
Priority: P3 → P2
Attached file PR for fix
Attachment #8556018 - Flags: review?(drs.bugzilla)
Attachment #8556018 - Flags: review?(drs.bugzilla) → review+
https://github.com/mozilla-b2g/gaia/commit/d83fd4f019c0553a10f06f620cf30cd521873194.

NI to myself to remember to ask for 2.2 approval
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(thills)
Resolution: --- → FIXED
Flags: in-moztrap+
Attached file 2.2 Uplift request
[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Support for RTL
[User impact] if declined: When in RTL languages, the parenthesis around the call count will be misplaced.
[Testing completed]:yes
[Risk to taking this patch] (and alternatives if risky):low
[String changes made]:no
Flags: needinfo?(thills)
Attachment #8557087 - Flags: approval-gaia-v2.2?(release-mgmt)
Attachment #8557087 - Flags: approval-gaia-v2.2?(release-mgmt) → approval-gaia-v2.2+
This issue has been verified successfully on Flame 3.0.
Reproduce rate:0/5.
Attachment:Verify_Counts.png

Flame 3.0 build:
Gaia-Rev        ae5a1580da948c3b9f93528146b007fc4f6a712b
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/ae5d04409cd9
Build-ID        20150203055658
Version         38.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150203.093120
FW-Date         Tue Feb  3 09:31:32 EST 2015
Bootloader      L1TC000118D0
QA Whiteboard: [MGSEI-Triage+]
Attached image Verify_Counts.png
This issue can't be repro on latest Flame 2.2
Reproduce rate:0/5

Flame 2.2 build:

Build ID               20150204162500
Gaia Revision          c2047a46e29696238e9b4c9caaba47736421449a
Gaia Date              2015-02-04 20:34:04
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/adfba0a07e9b
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150204.195445
Firmware Date          Wed Feb  4 19:54:56 EST 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
Attached image Verify_RTL.png
You need to log in before you can comment on or make changes to this bug.