[sms] thread view header font size always small even when there's plenty of room

RESOLVED DUPLICATE of bug 1094320

Status

RESOLVED DUPLICATE of bug 1094320
4 years ago
4 years ago

People

(Reporter: mikehenrty, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sms-papercuts])

Attachments

(1 attachment)

Created attachment 8526138 [details]
[screenshot] shrunked header

STR:

1.) Add a contact with a short name (3-4 characters).
2.) Send sms to this contact.

Expected result:
Contact name displays at full font size.

Actual Result:
Contact name is font size is shrunk.
Hey Julien,

Is it something that maybe eventually fixed by your work on gaia-header (eg. patches for bug 1094320 or bug 1089920)? Or we should investigate it further?

Thanks!
Flags: needinfo?(felash)
I think it should be fixed by bug 1094320, but not completely. Actually I think we should not add the "(+0)" part when it's 0, because gaia-header will take it into account when reading textContent even if it's "display: none".

Also in [1] there is a weird character after   (we don't see it in github), do you know why? And why do we need   btw?
Flags: needinfo?(felash)
(In reply to Julien Wajsberg [:julienw] from comment #2)
> I think it should be fixed by bug 1094320, but not completely. Actually I
> think we should not add the "(+0)" part when it's 0, because gaia-header
> will take it into account when reading textContent even if it's "display:
> none".

Yeah, in this case we should definitely fix this.

> Also in [1] there is a weird character after   (we don't see it in
> github), do you know why?

Well, looks like it's LRM, probably I missed that when I was experimenting with it :( 

> And why do we need   btw?

Mmm,   to have space between contact name and (+1), I believe it should play well with textContent, or we have problem with it?

Also how do you think, can we have something "simpler" then "Name (+1)" in header title for group MMS thread so that we don't need all that magic? :)
> Mmm,   to have space between contact name and (+1), I believe it should play well 
> with textContent, or we have problem with it?

No special problem, I just wonder why a normal space does not work?
(In reply to Julien Wajsberg [:julienw] from comment #4)
> > Mmm,   to have space between contact name and (+1), I believe it should play well 
> > with textContent, or we have problem with it?
> 
> No special problem, I just wonder why a normal space does not work?

I've just checked and think we don't need any whitespace char at all, default space between two bdi's looks good enough
Whiteboard: [sms-papercuts]
Bug 1094320 is not fixed, it improves the situation a lot.
crap; I meant "is now fixed".
Message thread headers (ie. contact names) are looking a lot better! Thanks.

The message list still displays the word "Messages" really tiny though :/
(In reply to Michael Henretty [:mhenretty] from comment #8)

> The message list still displays the word "Messages" really tiny though :/


Oh really? It does not happen for me :/
I mean, it happens sometimes in Firefox, so maybe there is a race.

Maybe my work in bug 1089920 will make this better; I'll comment here once it's finished, and if there still is an issue we  can file a separate bug. (unless you prefer to file a separate bug now and make it depend on bug 1089920?)
(In reply to Julien Wajsberg [:julienw] from comment #9)
> Maybe my work in bug 1089920 will make this better; I'll comment here once
> it's finished, and if there still is an issue we  can file a separate bug.
> (unless you prefer to file a separate bug now and make it depend on bug
> 1089920?)

Yeah, since this bug refers to the thread view and was fixed with bug 1094320, let's mark it a duplicate and file a new one about the messages header.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1094320
Filed bug 1112740 to track the "Messages" problem.
You need to log in before you can comment on or make changes to this bug.