Text in Help subview is using grayscale anti-aliasing while animating

REOPENED
Unassigned

Status

()

REOPENED
4 years ago
2 years ago

People

(Reporter: elbart, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Created attachment 8526235 [details]
help grayscale.png

Nightly 2014-11-20

After changing from mainpanel to the help-subview, the text noticeably changes from grayscale antialiasing to cleartype.

m-c:
Last good revision: b85c260821ab (2014-10-03)
First bad revision: 229801d17f7e (2014-10-04)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b85c260821ab&tochange=229801d17f7e

m-i:
Last good revision: 60e90dd7f64f
First bad revision: 7a45d556f280
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=60e90dd7f64f&tochange=7a45d556f280

fx-team:
Last good revision: 849c7d93fba1
First bad revision: cb6a72e1fd95
Pushlog:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=849c7d93fba1&tochange=cb6a72e1fd95

cb6a72e1fd95	Richard Marti — Bug 1008603 - Define panel-subviews background-color in platform files. r=dao
(Reporter)

Comment 1

4 years ago
Created attachment 8526238 [details]
help grayscale.mp4
(Reporter)

Updated

4 years ago
Blocks: 1008603
(In reply to Elbart from comment #0)
> Created attachment 8526235 [details]
> help grayscale.png
> 
> Nightly 2014-11-20
> 
> After changing from mainpanel to the help-subview, the text noticeably
> changes from grayscale antialiasing to cleartype.
> 
> m-c:
> Last good revision: b85c260821ab (2014-10-03)

What does "good" mean here? That the text used grayscale AA all the time or that it used cleartype throughout?
(In reply to Dão Gottwald [:dao] from comment #2)
> (In reply to Elbart from comment #0)
> > Created attachment 8526235 [details]
> > help grayscale.png
> > 
> > Nightly 2014-11-20
> > 
> > After changing from mainpanel to the help-subview, the text noticeably
> > changes from grayscale antialiasing to cleartype.
> > 
> > m-c:
> > Last good revision: b85c260821ab (2014-10-03)
> 
> What does "good" mean here? That the text used grayscale AA all the time or
> that it used cleartype throughout?

I'm fairly sure this used to be grayscale throughout, because the background wasn't opaque before the cset identified, which would have triggered grayscale AA.

It's possible we can make it use cleartype throughout assuming animations don't force it off by ensuring the background is opaque while animating as well (assuming that doesn't look too ugly of itself). If that is the case already, I'm not sure we can do anything here besides waiting for graphics/layout to allow this to be the case on animating backgrounds.
(In reply to :Gijs Kruitbosch from comment #3)
> (In reply to Dão Gottwald [:dao] from comment #2)
> > (In reply to Elbart from comment #0)
> > > Created attachment 8526235 [details]
> > > help grayscale.png
> > > 
> > > Nightly 2014-11-20
> > > 
> > > After changing from mainpanel to the help-subview, the text noticeably
> > > changes from grayscale antialiasing to cleartype.
> > > 
> > > m-c:
> > > Last good revision: b85c260821ab (2014-10-03)
> > 
> > What does "good" mean here? That the text used grayscale AA all the time or
> > that it used cleartype throughout?
> 
> I'm fairly sure this used to be grayscale throughout, because the background
> wasn't opaque before the cset identified, which would have triggered
> grayscale AA.

That's my understanding too, which then means that bug 1008603 didn't regress anything but was a step in the right direction, as subpixel AA is preferable over grayscale.
No longer blocks: 1008603
Depends on: 1008603
Summary: Help-subview changes from grayscale to cleartype antialiasing after animation → Text in Help subview is using grayscale anti-aliasing while animating
(Reporter)

Comment 5

4 years ago
(In reply to Dão Gottwald [:dao] from comment #4)
> That's my understanding too, which then means that bug 1008603 didn't
> regress anything but was a step in the right direction, as subpixel AA is
> preferable over grayscale.

Right, as Gijs Kruitbosch said, before it was grayscale-only.
I filed this just because there's now a noticeable change, depending on the Cleartype-settings of the user.
Can you still reproduce the issue in latest stable Firefox version or in latest Nightly?
Flags: needinfo?(elbart)
(Reporter)

Comment 7

2 years ago
Yes.
Flags: needinfo?(elbart)
Please attach as attachment here your about:support (use "copy text to clipboard" button) from Nightly.
Flags: needinfo?(elbart)
(Reporter)

Comment 9

2 years ago
It's not depending on gfx-card or driver-version.

In the latest nightlies all text-captions in the hamburglar-menu are flickering during that animation, in both the normal pane and the help-pane.
Flags: needinfo?(elbart)
I wasn't talking about dependency, I was talking about complete information from about:support from Nightly. Could you post it?

(In reply to Elbart from comment #9)
> In the latest nightlies all text-captions in the hamburglar-menu are
> flickering during that animation, in both the normal pane and the help-pane.
It's other bug (probably bug #1306670), not this one.
Flags: needinfo?(elbart)
I'm asking because it could be fixed in Nightly which contains fixes for bug #1007702 and bug #1303570,
about:support is needed for checking what preferences are modified and backended is used where.
It should be fixed starting from Mozilla Firefox 52 per:
- Skia being enabled by default(Windows - bug #1007702, Linux - bug #1278957, Mac - bug #1207332)
- bug #1303570 (leftovers will be tracked in bug #1307833).

Duping this bug to bug #1307833 to later easier tracking, instead of incomplete or worksforme, because of no reporter reply.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Component: Theme → Graphics: Text
No longer depends on: 1008603
Flags: needinfo?(elbart)
Product: Firefox → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 1307833
Using Skia doesn't magically make us use sub-pixel AA where we were using grayscale AA. Please test this before concluding that it's fixed.
Blocks: 1307833
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---

Comment 15

2 years ago
It does fixed? Or did I miss something?

Tested in 53.0a1 (2016-11-18) (32-bit)

Comment 16

2 years ago
Created attachment 8812370 [details]
tested as fixed in 11-28 nightly build

Comment 17

2 years ago
is*
Dão, are you still reproducing issues here or should this be marked fixed/duped after all?
Flags: needinfo?(dao+bmo)
I can still reproduce this with the latest Nightly on Windows 10.
Flags: needinfo?(dao+bmo)

Comment 20

2 years ago
Oh, never mind, it is just my testing error, I didn't take the screenshot fast enough.

Please help delete my attachment to reduce future confusion.

Updated

2 years ago
Attachment #8812370 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.