ebay.de - Not possible to subscribe to ebay!

VERIFIED FIXED

Status

P1
critical
VERIFIED FIXED
17 years ago
4 years ago

People

(Reporter: erik.fornoff, Assigned: tristan)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
Environment:
==============
OS: Win NT 4.0 SP-5
Mozilla BuildID:    2001111203



Summary:
=========
With the above mentioned version of Mozilla it#s not possible to make a new
sunscription to ebay.de 

Reproducible: yes


Steps to Reproduce:
====================

1. Start Mozilla & enter www.ebay.de to location bar

2. In the upcoming site click "Anmelden" in the middle-upper part of the window
to make a new subscription

3. On the next site choose "deutschland" in the listbox named "Wählen Sie das
Land aus, in dem Sie Ihren Wohnsitz haben:"

4. leave checkbox for SSL as is - it doesn't matter if its checked or not

5. click [Weiter] to go to the next step



Actual Results:  
================
After a few seconds a page stating that the entered information is wrong appears:

"Fehler bei der Eingabe
In Ihren Eingaben ist ein Fehler. Bitte gehen Sie zurück, und überprüfen Sie, ob
alle Felder ausgefüllt sind."

=> "Your entered data contains errors. Please go back and check, that all fields
have been filled"



Expected Results:  
==================
The next page asking for personal information appears



Additional Information:
========================
Problem does not occur using IE 5.5 and netscape 4.51
(Reporter)

Comment 1

17 years ago
I've set 

user_pref("dom.disable_open_during_load", true);

in the prefs.js - don't think this deals with the problem as no new window pops
up, but will try again after commenting the line...
(Reporter)

Comment 2

17 years ago
Commenting out the "disable_open_during_load"-line doesn't make any differences...

Comment 3

17 years ago
Using a sniffer and Mozilla 2001111403 on Win2k, the Web server send a 501 when
submitting the form according the this bug report.

POST /aw-cgi/eBayISAPI.dll? HTTP/1.1
Host: cgi4.ebay.de
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.5+)
Gecko/20011114
Accept: text/xml, application/xml, application/xhtml+xml, text/html;q=0.9,
image/png, image/jpeg, image/gif;q=0.2, text/plain;q=0.8, text/css, */*;q=0.1
Accept-Language: fr, en-us;q=0.50
Accept-Encoding: gzip, deflate, compress;q=0.9
Accept-Charset: ISO-8859-1, utf-8;q=0.66, *;q=0.66
Keep-Alive: 300
Connection: keep-alive
Cookie: lucky6=341275
Referer:
http://cgi4.ebay.de/aw-cgi/eBayISAPI.dll?SSLRegisterFromCountries&siteid=77&co_partnerid=2&UsingSSL=0
Content-type: application/x-www-form-urlencoded
Content-Length: 192

country=77&UsingSSL=1&MfcISAPICommand=RegisterByCountry&siteId=77&co_partnerId=2&aoluseremailid=default&encaoluseremailid=default&aolusermasterid=default&encaolusermasterid=default&rpaheader=0HTTP/1.0
501 Not Implemented
Server: Microsoft-IIS/4.0
Date: Thu, 15 Nov 2001 14:41:34 GMT
Content-Type: text/html
[...]

Whereas, with IE6.0 or NS4.76:

POST /aw-cgi/eBayISAPI.dll? HTTP/1.1
Accept: image/gif, image/x-xbitmap, image/jpeg, image/pjpeg,
application/vnd.ms-powerpoint, application/vnd.ms-excel, application/msword, */*
Referer:
http://cgi4.ebay.de/aw-cgi/eBayISAPI.dll?SSLRegisterFromCountries&siteid=77&co_partnerid=2&UsingSSL=0
Accept-Language: fr,en;q=0.5
Content-Type: application/x-www-form-urlencoded
Accept-Encoding: gzip, deflate
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Host: cgi4.ebay.de
Content-Length: 192
Connection: Keep-Alive
Cache-Control: no-cache
Cookie: lucky6=100466

MfcISAPICommand=RegisterByCountry&siteId=77&co_partnerId=2&aoluseremailid=default&encaoluseremailid=default&aolusermasterid=default&encaolusermasterid=default&rpaheader=0&country=77&UsingSSL=1
HTTP/1.0 302 Object Moved
Server: Microsoft-IIS/4.0
Date: Thu, 15 Nov 2001 14:45:54 GMT
Location:
https://scgi.ebay.de/saw-cgi/eBayISAPI.dll?EBayRegisterShow&countryid=77&co_partnerId=2&siteId=77&UsingSSL=1&am=default&amid=default&em=default&emid=default&rpaheader=0
[...]

Perhaps, the JavaScript used to build the request is badly behaving with
Mozilla, I don't know yet if it's Mozilla or Web page's fault.

Comment 4

17 years ago
I wonder if it's at all related to bug 91018 ?

Comment 5

17 years ago
->evangelism for a look.
Assignee: asa → bclary
Status: UNCONFIRMED → NEW
Component: Browser-General → English: US
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: doronr → zach
Version: other → unspecified

Comment 6

17 years ago
-> euro.

Tristan, we have other existing ebay issues which we may want to coordiante our
actions. Let's talk.
Assignee: bclary → nitot
Component: English: US → Europe: West
QA Contact: zach → caillon
Summary: Not possible to subscribe to ebay! → ebay.de - Not possible to subscribe to ebay!
(Assignee)

Comment 7

17 years ago
Bob : ok for a chat. See you in IRC.

Olivier : thanks for your help.

Contact info : http://pages.ebay.de/community/aboutebay/contact/index.html
No e-mail address mentionned. The Webmasters seems to be in switzerland.
Confirming on Moz 096/win2K and Linux. OS-> All
Setting P1.
OS: Windows NT → All
Priority: -- → P1

Comment 8

17 years ago
-> fixed, works fine in moz and ns6.2.1
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 9

17 years ago
Verified
2002040303/WinXP
Status: RESOLVED → VERIFIED
move...
Component: Europe: West → German
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.