[Bluetooth] Audio will cut out when opening and closing some apps

RESOLVED WONTFIX

Status

Firefox OS
Performance
P1
normal
RESOLVED WONTFIX
4 years ago
2 months ago

People

(Reporter: AdamA, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.6+, firefox45 affected, b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [2.2-Daily-Testing], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8526351 [details]
logcat

Description:
While listening to music the audio will cut out/be choppy while opening and closing some apps. I encountered this issue with the camera app, marketplace app, and when going to a site in the browser.

Repro Steps:
1) Update a Flame to 20141120040205
2) Connect a blurtooth headset
3) Play some music
4) Open camera app
5) Observe audio

Actual:
Audio cuts out while opening and closing some apps

Expected:
it is expected that bluetooth audio stays consistent

Environmental Variables:
Device: Flame 2.2 (Shallow Flash)(319mb)
Build ID: 20141120040205
Gaia: 1abe09b4925547699dfdb2d358aed019137c3aa6
Gecko: 6ce1b906c690
Version: 36.0a1 (2.2)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Repro frequency: 5/5
See attached: video clip(http://youtu.be/E5FdKkZUoeo), logcat

------------------------------------------------------------------------------------
This issue also occurs on 2.0 Flame, 2.1 Flame, and the previous 2.2 Flame.

Environmental Variables:
Device: Flame 2.2 (Shallow Flash)(319mb)
BuildID: 20141120040205
Gaia: 1abe09b4925547699dfdb2d358aed019137c3aa6
Gecko: 6ce1b906c690
Version: 36.0a1 (2.2) 
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Device: Flame 2.1 (319mb)(Shallow Flash)
BuildID: 20141120001207
Gaia: f8d3bf44029e0afc0124600a4bb34dba8fc1ad21
Gecko: f70a67a7f846
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.0 (319mb)(Shallow Flash)
BuildID: 20141120000206
Gaia: 1ede2666f1e6c1b3fd3b282011caf0cbc59544b0
Gecko: 54f1b0ee07a6
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Result:
Audio cuts out while opening and closing some apps
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
qawanted for base image branch checks.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: qawanted
This issue DOES repro on V181-1 base

Device: Flame 2.0
Build ID: 20141021162107
Gaia: 8c5c956ee6909408e29f375cc7d843a03d92f3d8
Gecko: 60bf345874982e25236ffb80f41e33fdb8ac94f9
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 32.0 (2.0)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Issue does NOT repro on v123 base

Device: Flame 1.3
Build ID: 20140627162151
Gaia: 5c43d012a9351e8aaeacda0b87b0886b7f67d33d
Gecko: e181a36ebafaa24e5390db9f597313406edfc794
Version: 28.0 (1.3)
Firmware Version: v123
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0
QA Whiteboard: [QAnalyst-Triage+]
Keywords: qawanted
Did you shallow Flash? It looks like a known issue of bluetooth stack (bug 1038134). I'm not sure t2m took the patch for v.188. But anyway, full flash images contain that patch.
Flags: needinfo?(aalldredge)
(Reporter)

Comment 4

3 years ago
I was shallow flashed when I encountered this issue.
Flags: needinfo?(aalldredge)
Duplicate of this bug: 1119935

Comment 6

2 years ago
ni? media dev Blake.

Blake, is this bug general audio bug instead of bluetooth one?
Flags: needinfo?(bwu)
I think this is an overall performance problem. When opening some apps, usually CPU could be busy, which causes BT fails to get the decoded audio data in time. 
For normal audio playback, like playing music with speaker, since AudioOffloadPlayer will be used, CPU doesn't need to spend much resource on it and playback will be smooth if user playing some heavy apps.   

I would suggest to change this component to be "Performance".
Component: Bluetooth → Performance
Flags: needinfo?(bwu)

Updated

2 years ago
Component: Performance → Bluetooth
Priority: -- → P2
Bobby, 
May I know the reasons you changed the component back to Bluetooth? :)
Flags: needinfo?(bchien)

Comment 9

2 years ago
Sorry, I didn't aware I change "component". I was trying to change priority.
Flags: needinfo?(bchien)

Comment 10

2 years ago
btw, could you identify this issue as a audio performance or general performance issue?
Component: Bluetooth → Performance

Updated

2 years ago
Flags: needinfo?(bwu)
(In reply to Bobby Chien [:bchien] from comment #10)
> btw, could you identify this issue as a audio performance or general
> performance issue?
I think it is a general performance issue since it only happens when user do something, like switch between APPs which make CPU busy.
Flags: needinfo?(bwu)

Comment 12

2 years ago
Reproduced. Affect all music playback, not only play to Bluetooth. But more audio cut in bluetooth use case. Also, Audio playback almost stop when switch to camera.

------

Following is CPU usage during playback to bluetooth and use camera.

User 36%, System 57%, IOW 0%, IRQ 0%
User 243 + Nice 0 + Sys 386 + Idle 35 + IOW 6 + IRQ 0 + SIRQ 2 = 672

  PID PR CPU% S  #THR     VSS     RSS PCY UID      Name
  209  0  33% R    61 330880K  50292K     root     /system/b2g/b2g
  302  0  17% S    17  41756K   7816K     camera   /system/bin/mm-qcamera-daemon
 5439  1   7% R    24 128256K  25208K  fg u0_a5439 /system/b2g/b2g
 3823  1   7% R    33 137436K  18496K unk u0_a3823 /system/b2g/b2g
  203  1   5% S    29  69124K   1520K  fg media    /system/bin/mediaserver
 5533  1   2% S    19  99484K   6796K  bg u0_a5533 /system/b2g/b2g
 2259  0   2% S    12  19528K   1056K     bluetoot /system/bin/bluetoothd

----

Build ID               20151206150208
Gaia Revision          b930e25e9f2e5ec2106dd31005468575cdf87d50
Gaia Date              2015-12-05 03:41:55
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cc9c6cd756cb744596ba039dcc5ad3065a7cc3ea
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150712.193621
Firmware Date          Sun Jul 12 19:36:34 EDT 2015
Bootloader             L1TC000118D0
blocking-b2g: --- → 2.6+
status-b2g-master: --- → affected
status-firefox45: --- → affected

Updated

2 years ago
Priority: P2 → P1

Comment 13

2 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.