Closed Bug 1102534 Opened 5 years ago Closed 4 years ago

[Homescreen] While in Edit mode user is able stretch the "Edit" text off of screen.

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: jthomas, Unassigned)

References

()

Details

(Keywords: regression, Whiteboard: [2.1-Exploratory-3])

Attachments

(1 file)

Description:
While the user is in Edit mode the "Edit" text can be stretched off of the top of the screen.
   
Repro Steps:
1) Update a Flame device to BuildID: 20141120001207
2) From the Homescreen press and hold an icon to enter "Edit mode".
3) Press and hold while scrolling up and down.

Actual:
Edit text can be stretched off the top of the screen.
  
Expected: 
It is expected that the Edit text will remain on the screen regardless of which direction the user is scrolling.
  
Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141120001207
Gaia: f8d3bf44029e0afc0124600a4bb34dba8fc1ad21
Gecko: f70a67a7f846
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
Repro frequency: 100%
See attached: Logcat & Video
Video: http://youtu.be/jX_wOcoCGnU
This issue DOES occur on Flame 2.2 KK (319mb) 
Result: Edit text can be stetched off of the screen while in Edit mode.

Flame 2.2

Device: Flame 2.2 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141120040205
Gaia: 1abe09b4925547699dfdb2d358aed019137c3aa6
Gecko: 6ce1b906c690
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

=========================================================================
This issue does NOT occur on the Flame 2.0 KK (319mb)

Flame 2.0
Result: Edit text remains in place regardless of stretching up and down.

Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141120000206
Gaia: 1ede2666f1e6c1b3fd3b282011caf0cbc59544b0
Gecko: 54f1b0ee07a6
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
This seems like a minor bug. Not nominating to block on this.

Also this seems to be related to bug 1096513
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris)
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.