Closed Bug 1102560 Opened 5 years ago Closed 5 years ago

Gip tests fail on gaia try for v2.1 pushes

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mikehenrty, Unassigned)

References

Details

No Gip tests run on gaia-try pushes for v2.1. We see the following error:

"ValueError: Total number of chunks must be between 1 and 0."


For instance:
https://tbpl.mozilla.org/?tree=Gaia-Try&rev=4f78c3712409

Talking to :jgriffin, it looks like no tests are being run, and it's trying to chunk 0 test. Possible manifest issue.
Dave, Malini, any ideas?
Flags: needinfo?(mdas)
Flags: needinfo?(dave.hunt)
It looks like the command-line is mangled; we're passing both --type=b2g and --type=b2g-external.  I'm not sure which it is supposed to be.  I know Zac had been working on a fix to this, so it may be a matter of uplifting something or finishing his work.
The first instance of this I see is the 2.1 pull request for bug 1099041: https://github.com/mozilla-b2g/gaia/pull/26149
Zac, see comment 2
Flags: needinfo?(zcampbell)
(In reply to Jonathan Griffin (:jgriffin) from comment #2)
> It looks like the command-line is mangled; we're passing both --type=b2g and
> --type=b2g-external.  I'm not sure which it is supposed to be.  I know Zac
> had been working on a fix to this, so it may be a matter of uplifting
> something or finishing his work.

Yep I have tried to address this in https://bugzilla.mozilla.org/show_bug.cgi?id=1084288.

I will nag releng about reviewing it, although I'm not sure it's the problem here.

Gip on b2g34_v2.1 branch is fine but it is not using chunking. I suppose that Gaia-Try on b2g32_v2.1 does not use the b2g34_v2.1 branch for environment configuration?
Flags: needinfo?(zcampbell)
Duplicate of this bug: 1102826
I've investigated this. 

The in-tree (b2g34_v2.1) branch packages are incompatible with the changes made in https://bugzilla.mozilla.org/show_bug.cgi?id=1099041 .

When these tests are run outside of the tree they are using mozilla-central branch packages which are more advanced.

I'll backout the Gaia patch that caused it.
I've backed out the blaming patch in bug 1099041.

It's now running all of the tests again:
https://treeherder.mozilla.org/ui/#/jobs?repo=gaia-try&revision=72231b602a1b
Status: NEW → RESOLVED
Closed: 5 years ago
Depends on: 1099041
Flags: needinfo?(mdas)
Flags: needinfo?(dave.hunt)
Resolution: --- → FIXED
(In reply to Zac C (:zac) from comment #5)
> 
> Gip on b2g34_v2.1 branch is fine but it is not using chunking. I suppose
> that Gaia-Try on b2g32_v2.1 does not use the b2g34_v2.1 branch for
> environment configuration?

Forgot to add that I do still think this is an issue but at the moment we're getting away with it.
You need to log in before you can comment on or make changes to this bug.