Horizontal scrollbar pops up/down when it shouldn't

VERIFIED FIXED in M12

Status

()

defect
P3
normal
VERIFIED FIXED
20 years ago
20 years ago

People

(Reporter: mats, Assigned: karnaze)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

Reporter

Description

20 years ago
Repeat by:
1. Goto http://www.mozilla.org/
2. Grab right border of window and resize the width

Expected:
If H. scrollbar is visible after page loaded: it should disappear when content
width is less than window width.
If H. scrollbar is not visible after page loaded: nothing really.

What actually happens:
Horizontal scrollbar pops up/down several times while monotonically increasing
window width.

I was using build 1999-07-31-08 on Windows 98.

Updated

20 years ago
Assignee: troy → beard
Component: Layout → Compositor

Comment 1

20 years ago
Works fine for me. Patrick, maybe it's a platform specific problem?

Updated

20 years ago
Status: NEW → ASSIGNED

Comment 2

20 years ago
I've seen this bug on and off. Doesn't happen on NT, does happen on Mac now and
then.

Updated

20 years ago
Target Milestone: M12

Comment 3

20 years ago
This bug happens a lot on http://www.mozillazine.org, as well. I suspect that
there's some kind of instability in the width of the scrolled view, such that
sometimes it is slightly wider than the clip view, and other times it isn't.

Updated

20 years ago
Assignee: beard → karnaze
Status: ASSIGNED → NEW
Component: Compositor → HTMLTables

Comment 5

20 years ago
Attached is a simpler test case that demonstrates this. Kipp and I believe this
is a table bug.
Assignee

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
Assignee

Comment 6

20 years ago
Fixed with latest checkin.
Reporter

Updated

20 years ago
Status: RESOLVED → REOPENED
Reporter

Comment 7

20 years ago
I see this bug on http://www.mozilla.org/ again using 1999-08-26-13-M10 on
Windows 98 SE. The test case above (id=1300) does not trigger it anymore.
Assignee

Comment 8

20 years ago
I'm not seeing it on a 8/24 NT build. I'll look at it again later.

Updated

20 years ago
Resolution: FIXED → ---

Comment 9

20 years ago
Clearing Fixed resolution due to reopen.
Reporter

Comment 10

20 years ago
Bug does not occur at http://www.mozilla.org/ anymore. But I have found another
one: http://www.microsoft.com so I'm changing the URL field.
Bug still occurs in apprunner 1999-10-09-09-M11 on Windows 98 SE.
Assignee

Updated

20 years ago
Status: REOPENED → RESOLVED
Last Resolved: 20 years ago20 years ago
Resolution: --- → FIXED
Assignee

Comment 11

20 years ago
Fixed with 10/13 checkin.

Comment 12

20 years ago
I'm not seeing this problem with the Oct 22 build. Reporter, can you verify this
bug using the latest build. Otherwises I will mark it verified.
Reporter

Updated

20 years ago
Status: RESOLVED → VERIFIED
Reporter

Comment 13

20 years ago
Verified fixed in 1999-10-24-09-M11 build on both Windows 98 and NT.
You need to log in before you can comment on or make changes to this bug.