Closed Bug 1102646 Opened 5 years ago Closed 5 years ago

[FTU] User is able to access New Tab menu during FTU.

Categories

(Firefox OS Graveyard :: Gaia::First Time Experience, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED DUPLICATE of bug 1088461
Tracking Status
b2g-v2.0 --- affected
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: jthomas, Unassigned)

References

()

Details

(Whiteboard: [2.1-exploratory-3][systemsfe])

Attachments

(1 file)

Description:
During the FTU the user is able to Open a New tab after selecting one of the Mozilla Privacy links. 


Repro Steps:
1) Update a Flame to 20141120001207
2) Enter FTU
3) Enable a Wifi connection or Data
4) Navigate to the About Firefox OS page.
5) Select the bold Privacy Notice page.
6) Click and hold the "Mozilla Privacy Policy" page.
7) Select "Open link in new tab".

Note:
There are 2 pages with the Firefox OS title. This issue can be accessed on both pages.
This issue can ALSO be accessed from the About Firefox

Please also see this bug as it is related to this issue occurring on the Geolocation bug.
https://bugzilla.mozilla.org/show_bug.cgi?id=1088461

Actual:
User is able to escape the FTU by opening a link as new window.

Expected:
It is expected that the user will not be able to leave the FTU until it is completed.

Environmental Variables:
Device: Flame 2.1 KK (319MB) (shallow flash)
Build ID: 20141120001207
Gaia: f8d3bf44029e0afc0124600a4bb34dba8fc1ad21
Gecko: f70a67a7f846
Version: 34.0 (2.1)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Repro frequency: 100%
See attached: Logcat & Video
Video: http://youtu.be/FM4JdXK2JkI
This issue DOES occur on Flame 2.2 KK (319mb) and Flame 2.0 KK (319mb)
Result: User is able to escape the FTU by opening a link as new window.

Flame 2.2

Device: Flame 2.2 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141120040205
Gaia: 1abe09b4925547699dfdb2d358aed019137c3aa6
Gecko: 6ce1b906c690
Version: 36.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Flame 2.0

Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141120000206
Gaia: 1ede2666f1e6c1b3fd3b282011caf0cbc59544b0
Gecko: 54f1b0ee07a6
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
It seems like this bug is either a dupe of the bug mentioned in comment 0 (bug 1088461), or that bug 1088461 is a bug of a bug. NI FTE owner to weigh in on this.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(dharris) → needinfo?(mozillamarcia.knous)
(In reply to Derek Harris [:DerekH] from comment #2)
> It seems like this bug is either a dupe of the bug mentioned in comment 0
> (bug 1088461), or that bug 1088461 is a bug of a bug. NI FTE owner to weigh
> in on this.

Yeah this is another manifestation of bug 1088461. Preventing the user from escaping the FTU in the first place doesn't seem practical, the plan is to have the 'home' button return the user to the FTU when the FTU is running. We've not set scope for 2.2 yet, but it seems 1088461 should be a candidate.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(mozillamarcia.knous)
Resolution: --- → DUPLICATE
Duplicate of bug: 1088461
You need to log in before you can comment on or make changes to this bug.