Closed Bug 1102650 Opened 6 years ago Closed 6 years ago

Selectors with the pseudo class :(-moz-)dir() should be valid when the argument is a valid identifier

Categories

(Core :: CSS Parsing and Computation, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla36

People

(Reporter: benjamin, Assigned: dbaron)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_2) AppleWebKit/600.3.6 (KHTML, like Gecko) Version/8.0.2 Safari/600.3.6

Steps to reproduce:

See the following codepen: http://codepen.io/anon/pen/ZYYRrj


Actual results:

The text should be styled green.


Expected results:

The selector is considered invalid. It should be matching nothing instead (http://dev.w3.org/csswg/selectors4/#the-dir-pseudo).

Since it is considered invalid, the universal selector is ignored.

Kudos to Sukolsak Sakshuwong for catching the bug.
Yeah, I don't see any rationale for why it was done the way our code does it.
Assignee: nobody → dbaron
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
OS: Mac OS X → All
Hardware: x86 → All
Comment on attachment 8526592 [details] [diff] [review]
Make the :-moz-dir() and :-moz-locale-dir() selectors be valid selectors (matching nothing) with arguments other than rtl and ltr, rather than invalid

I assume it's OK that we serialize values other than "ltr" and "rtl" after converting them to lowercase?
Attachment #8526592 - Flags: review?(cam) → review+
I think so, given that CSS values are all case-insensitive, and the values likely to be added are things like tb-rl and tb-lr, or maybe ttb.
https://hg.mozilla.org/mozilla-central/rev/0ae211c02f12
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
You need to log in before you can comment on or make changes to this bug.