TrackUnionStreams report they have current data when they have no inputs

RESOLVED FIXED in mozilla36

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: pehrsons, Assigned: pehrsons)

Tracking

Trunk
mozilla36
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

TrackUnionStreams can prematurely report HaveCurrentData because their input streams have no tracks. This happens often for media element capturing when the TrackUnionStream is created before the source media element has written any data to its output stream.
Assignee: nobody → pehrsons
Blocks: 879717
Status: NEW → ASSIGNED
I got the description a bit wrong. The issue is when there are no input streams. Existing input streams without tracks is OK.
Summary: TrackUnionStreams report they have current data when they have no tracks → TrackUnionStreams report they have current data when they have no inputs
https://hg.mozilla.org/mozilla-central/rev/790f6eefaa6a
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
You need to log in before you can comment on or make changes to this bug.