Closed Bug 1102672 Opened 7 years ago Closed 7 years ago

[FFOS2.0][Call][Hotseat]When press home key to make the call in background, the hotseat will jump down and display incomplete for a momentary.

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect, P2)

defect

Tracking

(b2g-v2.0 unaffected, b2g-v2.0M unaffected, b2g-v2.1 unaffected, b2g-v2.2 unaffected)

RESOLVED INVALID
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.0M --- unaffected
b2g-v2.1 --- unaffected
b2g-v2.2 --- unaffected

People

(Reporter: sync-1, Unassigned)

References

Details

Attachments

(2 files)

Created an attachment (id=1011864)
 video
 
 DEFECT DESCRIPTION:
 When press home key to make the call in background, the hotseat will jump down and display incomplete for a momentary.
 
  REPRODUCING PROCEDURES:
 1.Established a call.
 2.Press home key to make the call in background.
 3.Observe the homescreen display.
 >The hotseat will jump down and display incomplete for a momentary.-KO
 
  EXPECTED BEHAVIOUR:
 Should not jump down and should always display complete.
 >TEL:0752-2611945(61945)
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
Attached video video
Blocks: Woodduck
Hi Gary,
Could you please help to check the problem? Thanks!
Flags: needinfo?(gchen)
blocking-b2g: --- → 2.0M?
Hi Norry,
qawanted for Woodduck 2.0M and Flame 2.0/2.1/2.2. Thanks!
Keywords: qawanted
it's fire fox 2.0 issue.
Triage:
polish issue.
blocking-b2g: 2.0M? → ---
Keywords: polish
Hi Gary,
Maybe a nice first bug?
any updates?
 if we can get patch for fix it?
 or it don't need to fix?
(In reply to Josh Cheng [:josh] from comment #3)
> Hi Norry,
> qawanted for Woodduck 2.0M and Flame 2.0/2.1/2.2. Thanks!

Needinfo Norry for you since I'm sure Norry isn't notified about the task without the NI. We can help with branch checks on Flame.

-----

I'm unable to get the homescreen to display like demonstrated in the video. I can only use vertical homescreen and issue doesn't repro on vertical homescreen. The Homescreen option in Settings only provides option to change number of icons per row.

Issue does NOT occur on Flame 2.0, Flame 2.1, and Flame 2.2.

Observed behavior: Pressing Home button while in a call and the Homescreen displays correctly.

Device: Flame 2.0
BuildID: 20141202035701
Gaia: 8d1e868864c8a8f1e037685f0656d1da70d08c06
Gecko: 29222e215db8
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Device: Flame 2.1
BuildID: 20141202061559
Gaia: a684b82a19dd1939ca6e75e60a6203327b333c2a
Gecko: a7f6a3cc59bc
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Device: Flame 2.2 Master
BuildID: 20141202025557
Gaia: 725685831f5336cf007e36d9a812aad689604695
Gecko: 22ad8a162cf3
Version: 37.0a1 (2.2 Master)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

-----

Norry, please remove qawanted tag once Woodduck has been checked. Thanks.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Flags: needinfo?(fan.luo)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
Attached video Verify.mp4
On woodduck 2.0M, I can't repro this bug like what is showing in the video, and as same as comment 8, I can only use vertical homescreen and issue doesn't repro on vertical homescreen. The Homescreen option in Settings only provides option to change number of icons per row.

Observed behavior: Pressing Home button while in a call and the Homescreen displays correctly.

Rate: 0/5

Woodduck build:
Gaia-Rev        0e4a94fca05719b49139a7d5267e5fb3ea5c3449
Gecko-Rev       93efc8b4155f0a4a50eaad19acbb95ec24139e63
Build-ID        20141203050313
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1417554324
FW-Date         Wed Dec  3 05:05:48 CST 2014
Flags: needinfo?(fan.luo)
Status: NEW → RESOLVED
Closed: 7 years ago
Keywords: polish
Resolution: --- → INVALID
Blocks: Woodduck_P2
we have fixed it on PR-835195.
 please close this bug. thanks a lot
please test it on:
 Version:sw7G1b+zz
per comment #10, clear ni.
Flags: needinfo?(gchen)
You need to log in before you can comment on or make changes to this bug.