[Telephony] Support change Supplementary Services password through MMI code

RESOLVED FIXED in 2.2 S3 (9jan)

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: aknow, Assigned: aknow)

Tracking

unspecified
2.2 S3 (9jan)
x86_64
Linux
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking-b2g:2.0M+, b2g-v2.0 wontfix, b2g-v2.0M fixed, b2g-v2.1 wontfix, b2g-v2.2 fixed)

Details

Attachments

(5 attachments, 2 obsolete attachments)

(Assignee)

Description

4 years ago
3GPP TS 22.030
6.5.4 Registration of new password

* 03 * ZZ * OLD_PASSWORD * NEW_PASSWORD * NEW_PASSWORD #

The UE shall also support the alternative procedure: 

** 03 * ZZ * OLD_PASSWORD * NEW_PASSWORD * NEW_PASSWORD # 

where, for Barring Services, ZZ = 330; 

for a common password for all appropriate services, delete the ZZ, entering: 

* 03 ** OLD_PASSWORD * NEW_PASSWORD * NEW_PASSWORD # 

The UE shall also support the alternative procedure: 

** 03 ** OLD_PASSWORD * NEW_PASSWORD * NEW_PASSWORD #
(Assignee)

Comment 1

4 years ago
Created attachment 8533628 [details] [diff] [review]
Part 1: Support change barring password
Attachment #8533628 - Flags: review?(htsai)
(Assignee)

Comment 2

4 years ago
Created attachment 8533629 [details] [diff] [review]
Part 2: Test change barring password
Attachment #8533629 - Flags: review?(htsai)
Comment on attachment 8533628 [details] [diff] [review]
Part 1: Support change barring password

Review of attachment 8533628 [details] [diff] [review]:
-----------------------------------------------------------------

Overall it looks good except one question :)

::: dom/system/gonk/ril_worker.js
@@ +6056,5 @@
> +    this.sendChromeMessage(options);
> +    return;
> +  }
> +
> +  options.statusMessage = MMI_SM_KS_PASSWORD_CHANGED;

Do we really want to statusMessage MMI_SM_KS_PASSWORD_CHANGED even when rilRequestError is true?
Attachment #8533628 - Flags: review?(htsai)
Comment on attachment 8533628 [details] [diff] [review]
Part 1: Support change barring password

Review of attachment 8533628 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/system/gonk/ril_worker.js
@@ +6056,5 @@
> +    this.sendChromeMessage(options);
> +    return;
> +  }
> +
> +  options.statusMessage = MMI_SM_KS_PASSWORD_CHANGED;

Ignore my comment 3. 
Though we don't really care "statusMessage" in error cases, this is okay :) Thanks!
Attachment #8533628 - Flags: review+
Comment on attachment 8533629 [details] [diff] [review]
Part 2: Test change barring password

Review of attachment 8533629 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me! Thank you.
Attachment #8533629 - Flags: review?(htsai) → review+
https://hg.mozilla.org/mozilla-central/rev/88787e45d2e1
https://hg.mozilla.org/mozilla-central/rev/de099dd00df8
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → 2.2 S3 (9jan)
(Assignee)

Comment 9

4 years ago
ni Josh for 2.0m? because it's the bug for Bug 1098978.
blocking-b2g: --- → 2.0M?
Flags: needinfo?(jocheng)

Updated

4 years ago
Duplicate of this bug: 1098978

Updated

4 years ago
blocking-b2g: 2.0M? → 2.0M+
status-b2g-v2.0: --- → wontfix
status-b2g-v2.0M: --- → affected
status-b2g-v2.1: --- → affected
status-b2g-v2.2: --- → fixed
Flags: needinfo?(jocheng)
(Assignee)

Comment 11

4 years ago
ni myself for 2.0m patch
Flags: needinfo?(szchen)
(Assignee)

Comment 12

4 years ago
Created attachment 8541055 [details] [diff] [review]
(2.0m) [final] Support change barring password. r=hsinyi
Flags: needinfo?(szchen)
Attachment #8541055 - Flags: review+
(Assignee)

Comment 13

4 years ago
Created attachment 8541056 [details] [diff] [review]
(2.1) [final] Support change barring password. r=hsinyi
Attachment #8541056 - Flags: review+
(Assignee)

Comment 14

4 years ago
Created attachment 8541375 [details] [diff] [review]
Part 3: Add missing semicolon
Attachment #8541375 - Flags: review?(htsai)
Attachment #8541375 - Flags: review?(htsai) → review+
(Assignee)

Comment 15

4 years ago
https://hg.mozilla.org/integration/b2g-inbound/rev/579cfc80a665

This is a follow-up patch which fixes the following issue. I am sorry to cause the problem in previous patches.

TEST-UNEXPECTED-FAIL | test_ril_code_quality.py TestRILCodeQuality.test_ril_consts | AssertionError: See errors below and more information in Bug 880643
(Assignee)

Comment 16

4 years ago
Comment on attachment 8541056 [details] [diff] [review]
(2.1) [final] Support change barring password. r=hsinyi

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): new feature not supported before
User impact if declined: user cannnot change call barring password through mmi code
Testing completed: N/A
Risk to taking this patch (and alternatives if risky): low ~ mid
String or UUID changes made by this patch: N/A
Attachment #8541056 - Flags: approval-mozilla-b2g34?
(Assignee)

Comment 17

4 years ago
check-in needed for 2.0m and 2.1
Keywords: checkin-needed
(Assignee)

Comment 19

4 years ago
check-in needed for 2.0m
Flags: needinfo?(kli)
https://hg.mozilla.org/releases/mozilla-b2g32_v2_0m/rev/08ebfa341006
status-b2g-v2.0M: affected → fixed
Flags: needinfo?(kli)
Backouted on 2.0m: https://hg.mozilla.org/releases/mozilla-b2g32_v2_0m/rev/96d4f5da6196

Aknow, Could you help to update the patch? Thanks!
status-b2g-v2.0M: fixed → affected
Flags: needinfo?(szchen)
(Assignee)

Comment 22

4 years ago
Created attachment 8542026 [details] [diff] [review]
(2.0m) [final#2] Support change barring password. r=hsinyi
Attachment #8541055 - Attachment is obsolete: true
Flags: needinfo?(szchen)
Attachment #8542026 - Flags: review+
(Assignee)

Comment 23

4 years ago
Created attachment 8542028 [details] [diff] [review]
(2.1) [final#2] Support change barring password. r=hsinyi
Attachment #8541056 - Attachment is obsolete: true
Attachment #8541056 - Flags: approval-mozilla-b2g34?
Attachment #8542028 - Flags: review+
(Assignee)

Updated

4 years ago
Attachment #8542028 - Attachment description: (2.1) [final] Support change barring password. r=hsinyi → (2.1) [final#2] Support change barring password. r=hsinyi
(Assignee)

Comment 24

4 years ago
(In reply to Kai-Zhen Li [:seinlin] from comment #21)
> Backouted on 2.0m:
> https://hg.mozilla.org/releases/mozilla-b2g32_v2_0m/rev/96d4f5da6196
> 
> Aknow, Could you help to update the patch? Thanks!

Updated. Sorry for the error.
(Assignee)

Updated

4 years ago
Flags: needinfo?(kli)
https://hg.mozilla.org/releases/mozilla-b2g32_v2_0m/rev/9804735ff433
status-b2g-v2.0M: affected → fixed
Flags: needinfo?(kli)
Comment on attachment 8542028 [details] [diff] [review]
(2.1) [final#2] Support change barring password. r=hsinyi

As per comment 16.
Attachment #8542028 - Flags: approval-mozilla-b2g34?
Comment on attachment 8542028 [details] [diff] [review]
(2.1) [final#2] Support change barring password. r=hsinyi

We cannot be adding new features so late in the game, so minusing for 2.1. This will ride the trains and partner can have it in 2.2.
Attachment #8542028 - Flags: approval-mozilla-b2g34? → approval-mozilla-b2g34-
status-b2g-v2.1: affected → wontfix

Updated

4 years ago
Blocks: 1179745

Updated

4 years ago
No longer blocks: 1179745
You need to log in before you can comment on or make changes to this bug.