Permission denied to push changes into projects/metro

RESOLVED FIXED

Status

Developer Services
Mercurial: hg.mozilla.org
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Maksim Lebedev, Assigned: fubar)

Tracking

Details

(Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/4176] )

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141105223254

Steps to reproduce:

$ hg push -v
pushing to ssh://hg.mozilla.org/projects/metro
Enter passphrase for key 'd:/WORK/FIREFOX/.ssh/id_rsa':
searching for changes
4 changesets found
remote: abort: could not lock repository /repo/hg/mozilla/projects/metro: Permission denied
abort: unexpected response: empty string


Actual results:

Public key is situated in Bug 984342
Commit access is in Bug 1088537
But permission is still denied.


Expected results:

I would like to take possibility to push changes at least into projects/metro.
Maybe access will be denied for all other trees and branches, except projects/metro.
(Reporter)

Updated

3 years ago
Depends on: 984342, 1088537
did you follow the self-heal steps at https://developer.mozilla.org/en-US/docs/Mercurial_FAQ#Help.2C_I_can.27t_push.21 yet?
(Reporter)

Comment 2

3 years ago
$ ssh hg.mozilla.org
Enter passphrase for key 'd:/WORK/FIREFOX/.ssh/id_rsa':
No interactive shells allowed here!
Connection to hg.mozilla.org closed.

Comment 3

3 years ago
(In reply to Justin Wood (:Callek) from comment #1)
> did you follow the self-heal steps at
> https://developer.mozilla.org/en-US/docs/Mercurial_FAQ#Help.2C_I_can.
> 27t_push.21 yet?

This FAQ seems a little out of date, I get the same thing here - 

jim@CAGE ~
$ ssh hg.mozilla.org
No interactive shells allowed here!
Connection to hg.mozilla.org closed.

and my access to hg is fine.

Comment 4

3 years ago
In my bash startup I also launch the ssh auth helper app via - 

ssh-add ~/.ssh/id_rsa

which leaves ssh-agent.exe running and handles all my auth. Maksim, is this setup on your end?
(Reporter)

Comment 5

3 years ago
(In reply to Jim Mathies [:jimm] from comment #4)
> ssh-add ~/.ssh/id_rsa
> which leaves ssh-agent.exe running and handles all my auth. Maksim, is this
> setup on your end?
Look's like it only remembered my auth key, and didn't ask me again due to push. But it didn't help me.
>$ ssh-add @path@/id_rsa
Enter passphrase for @path@/id_rsa:
Identity added: @path@/id_rsa (@path@/id_rsa)
>$ hg push -v
pushing to ssh://hg.mozilla.org/projects/metro
searching for changes
4 changesets found
remote: abort: could not lock repository /repo/hg/mozilla/projects/metro: Permission denied
abort: unexpected response: empty string

Updated

3 years ago
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/4176]
(Assignee)

Comment 6

3 years ago
projects/metro requires scm_level_3 access:

sekrit$ ssh hg.mozilla.org repo-group projects/metro
scm_level_3

Comment 7

3 years ago
(In reply to Kendall Libby [:fubar] from comment #6)
> projects/metro requires scm_level_3 access:
> 
> sekrit$ ssh hg.mozilla.org repo-group projects/metro
> scm_level_3

can we change that to level 2 please?

Updated

3 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 8

3 years ago
(In reply to Jim Mathies [:jimm] from comment #7)
> (In reply to Kendall Libby [:fubar] from comment #6)
> > projects/metro requires scm_level_3 access:
> can we change that to level 2 please?
Maybe someone can add only me to access users? - it will be more good for privacy policy.
(In reply to Jim Mathies [:jimm] from comment #7)
> (In reply to Kendall Libby [:fubar] from comment #6)
> > projects/metro requires scm_level_3 access:
> > 
> > sekrit$ ssh hg.mozilla.org repo-group projects/metro
> > scm_level_3
> 
> can we change that to level 2 please?

Jim - the implication of level 2 is that the repo can't be merged back into mainline without a complete code review of diffs. If you keep it level 3, then the appropriate level of reviews will already have been done.

I'm unaware of metro plans at this point, but if you're fine with taking on the review burden, we can downgrade. (Most project/* repos are level2 by default.)
(In reply to Maksim Lebedev from comment #8)
> (In reply to Jim Mathies [:jimm] from comment #7)
> > (In reply to Kendall Libby [:fubar] from comment #6)
> > > projects/metro requires scm_level_3 access:
> > can we change that to level 2 please?
> Maybe someone can add only me to access users? - it will be more good for
> privacy policy.

Nope - we do not have that level of access control on public mozilla.org repositories.

Comment 11

3 years ago
(In reply to Hal Wine [:hwine] (use needinfo) from comment #9)
> (In reply to Jim Mathies [:jimm] from comment #7)
> > (In reply to Kendall Libby [:fubar] from comment #6)
> > > projects/metro requires scm_level_3 access:
> > > 
> > > sekrit$ ssh hg.mozilla.org repo-group projects/metro
> > > scm_level_3
> > 
> > can we change that to level 2 please?
> 
> Jim - the implication of level 2 is that the repo can't be merged back into
> mainline without a complete code review of diffs. If you keep it level 3,
> then the appropriate level of reviews will already have been done.
> 
> I'm unaware of metro plans at this point, but if you're fine with taking on
> the review burden, we can downgrade. (Most project/* repos are level2 by
> default.)

Yep, lets do this. If we ever merge it back.. been there, done that with Elm.
(Assignee)

Comment 12

3 years ago
Done!

sekrit$ ssh hg.mozilla.org repo-group projects/metro
scm_level_2

Maksim, you should be set to push. Please re-open if you encounter further issues.
Assignee: nobody → klibby
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 13

3 years ago
Now, pushing is work.
You need to log in before you can comment on or make changes to this bug.