Closed Bug 1102817 Opened 7 years ago Closed 6 years ago

[FFOS2.0][Woodduck][Monitor][Contacts]The Keyboard will appear when click "Gmail" or "Outlook".

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect, P2)

defect

Tracking

(b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 unaffected)

RESOLVED INVALID
Tracking Status
b2g-v2.0 --- unaffected
b2g-v2.1 --- unaffected
b2g-v2.2 --- unaffected

People

(Reporter: sync-1, Unassigned)

References

Details

Attachments

(3 files)

Created an attachment (id=1021397)
 Keyboard
 
 DEFECT DESCRIPTION:
 The Keyboard will appear.
 
  REPRODUCING PROCEDURES:
 Enter Contacts->Settings->Import contacts->Gmail/Outlook
 
  EXPECTED BEHAVIOUR:
 The Keyboard shouldn't appear.
 
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
 
  该问题出现概率不高
Attached file Keyboard
Attached image Keyboard
Hi Gary,
Could you please help to check the problem? Thanks!
Flags: needinfo?(gchen)
Blocks: Woodduck
Keywords: qawanted
Hi Norry,
qawanted for Woodduck 2.0M and Flame 2.0/2.1/2.2. Thanks!
Flags: needinfo?(fan.luo)
I can not reproduce on v2.0m black woodduck.
Flags: needinfo?(gchen)
I checked on my flame to get some results here as well as what Norry can provide. I checked on the latest Engineering builds.

This bug does NOT repro on Flame kk build: Flame 2.2 KK, Flame 2.1 KK, Flame 2.0 KK

Actual Result: Keyboard is not appearing on the Import Contacts screen as shown in the screenshot on any of the flame builds below. Since the STR seem very straight forward, I Halo tested around this area to see if I could trick the keyboard into staying up on this screen but had no success.

Repro Rate: 0/9

Environmental Variables:
Device: Flame 2.2 KK
BuildID: 20141125035634
Gaia: 824a61cccec4c69be9a86ad5cb629a1f61fa142f
Gecko: acde07cb4e4d
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.1 KK
BuildID: 20141124205132
Gaia: 1bdd49770e2cb7a7321e6202c9bf036ab5d8f200
Gecko: db893274d9a6
Version: 34.0 (2.1) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.0 KK
BuildID: 20141124161832
Gaia: 99e4594c66aa3738d58b0cb44bd885a87a063b6e
Gecko: f91abc6127d9
Version: 32.0 (2.0) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

-----------------------------------------------------------------
-----------------------------------------------------------------

Also tried to reproduce on a couple user builds from the 11/21 to get more coverage but again had no luck.

Environmental Variables:
Device: Flame 2.0 Nightly
BuildID: 20141121000203
Gaia: 626d4d11a8c7e55022c1f364abb72ea340e2f1e7
Gecko: 74a294e72d0a
Version: 32.0 (2.0) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
-----------------------------------------------------------------
Environmental Variables:
Device: Flame 2.2 Nightly
BuildID: 20141121040204
Gaia: 25388c6bce932657ebf93adedf31881bfaf88c15
Gecko: 3366c0fcf9c2
Version: 36.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Changing this to steps-wanted to try and find consistent repro steps.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: qawantedsteps-wanted
Attached video Verify.mp4
I can't repro it on Woodduck 2.0m and Flame 2.0/2.1/2.2

Woodduck 2.0M build info:
d742e375aca6dc1bf3a36638000ad7f5338ef457
Gecko-Rev       d049d4ef127844121c9cf14d2e8ca91fd9045fcb
Build-ID        20141126050313
Version         32.0
Device-Name     jrdhz72_w_ff
FW-Release      4.4.2
FW-Incremental  1416949523
FW-Date         Wed Nov 26 05:05:47 CST 2014
Flags: needinfo?(fan.luo)
Hi Reporter,
We cannot reproduce this issue on our side. Could you please provide exact STR which can reproduce this problem again?
Flags: needinfo?(sync-1)
hi mozilla:
    this PR is very difficult to reproduce.Can you give me an idea to avoid it? Thanks
In the latest Flame 2.2 I see the keyboard coming up when I press Outlook, but the email text box is automatically selected and typing the works as expected.  Is this possibly what the reporter was seeing?

Environmental Variables:
Device: Flame 2.2
BuildID: 20141216130413
Gaia: 8ffb48c321bb9595ad437086c5eb450bc90aa714
Gecko: 8401afdb6e6c
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 37.0a1 (2.2) 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jocheng)
Flags: needinfo?(jmitchell)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
hi mozilla:
    Yes,The phenomenon is the same as me.
Hi Gary,
Per comment 11 and comment 12. It is not common issue but still worth checking. Can we provide suggestion maybe partner can fix this themselves?
Flags: needinfo?(sync-1)
Flags: needinfo?(jocheng)
Flags: needinfo?(gchen)
Hi all,
   If you want to show keyboard automatically, you should let input element focused when your app launched then you will see keyboard coming up automatically.

   So in this case, I think "gmail" or "outlook" set their input focus automatically so user will see the keyboard coming up after tapping the button.
Flags: needinfo?(gchen)
Hi, is there any update on this? Could you please try gary's suggestion in comment 14?
Flags: needinfo?(sync-1)
Blocks: Woodduck_P2
Flags: needinfo?(chen.ding)
Triage:
The import page will redirect to Google and Microsoft login page which keyboard focus is controlled by the website instead of Mozilla.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(sync-1)
Flags: needinfo?(chen.ding)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.