Recommendations checkbox does not work correctly

RESOLVED WONTFIX

Status

Marketplace
Consumer Pages
P2
normal
RESOLVED WONTFIX
4 years ago
3 years ago

People

(Reporter: Victor Carciu, Unassigned)

Tracking

Avenir
2015-11-10
x86_64
Windows 7
Points:
---

Details

(Whiteboard: [ktlo], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Prerequisites:
Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0

Steps to reproduce:
1. Sign to MP-dev and load Settings page (https://marketplace-dev.allizom.org/settings)
2. Uncheck "Recommendations" checkbox
3. Click “Save Changes” button

Expected results:
The “Recommended” menu link is no longer displayed

Actual results:
The “Recommended” link is still displayed on the page menu

Please see screencast for this bug : http://screencast.com/t/OFrxSVTE
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1097332

Comment 2

4 years ago
I'll open this bug because recommendations checkbox does not work correctly in production.
STR:
-load MP-prod settings page https://marketplace.firefox.com/settings
-uncheck recommendations checkbox
-click "Save changes" button
-refresh the page

expected results:
The “Recommended” link is not displayed on the page menu

actual results:
The “Recommended” link is displayed on the page menu and the checkbox is checked.

Please see screencast: http://screencast.com/t/crIxw4qKcB
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

3 years ago
Priority: -- → P2
No longer blocks: 1135257
Whiteboard: [ktlo]
Assignee: nobody → mstriemer
Created attachment 8630367 [details]
console log
I thought I had a solution for this, but it seems to fail differently on -dev and locally. See attached console log -- the log reports a GET call for consumer-info but the returned enable_recommendations value is not the same as the one sent in the previous PATCH request.

(I discussed a problem with mat about the wrong url being cache-busted, and that a request to consumer-info was being made without a region param. I can't currently repro this on -dev.)
Blocks: 1188073
No longer blocks: 1135257
Blocks: 1205830
No longer blocks: 1188073
Duplicate of this bug: 1218835

Updated

3 years ago
Assignee: mstriemer → nobody

Updated

3 years ago
Target Milestone: 2014-11-25 → 2015-11-10
https://github.com/mozilla/fireplace/commit/4f45fcebfc3a5677e8993cc1483304b6844d588f
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

3 years ago
The recommendations section is not displayed anymore after a page refresh even if no changes were made in Settings : http://screencast.com/t/ifqb68t3Jkv
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Recommendations will most likely be decommissioned as we transition to maintenance mode.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.