Remove some deprecated field names we said we'd kill in 5.0

RESOLVED WORKSFORME

Status

()

--
enhancement
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: gerv, Unassigned)

Tracking

Details

The release notes for 4.0 say:

  <li><kbd>Bug.attachments</kbd> now returns the attachment's description
    using the name "summary" instead of the name "description", to be
    consistent with the fact that bug summaries are called
    "summary". The value is still <em>also</em> returned as "description",
    for backwards compatibility, but this backwards compatibility will go
    away in Bugzilla 5.0.</li>
  <li>In the return values of various <kbd>Bug</kbd> functions, the author
    of comments, bugs, and attachments is now called "creator",
    instead of sometimes being called "reporter", "author", or "attacher".
    The old names are retained for backwards-compatibility, and will stay
    around until Bugzilla 5.0.</li>

We should remove the deprecated names on trunk, and maybe in the 5.0 branch too.

Gerv

Updated

4 years ago
Severity: normal → enhancement
OS: Linux → All
Hardware: x86 → All
These seem to have been done already.

Gerv
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.