Closed Bug 1102948 Opened 8 years ago Closed 8 years ago

Pressing tab no longer results in an autofill of the first suggestion displayed in the search pane

Categories

(Firefox :: Search, defect)

34 Branch
defect
Not set
normal

Tracking

()

RESOLVED INVALID
Tracking Status
firefox33 --- unaffected
firefox34 + wontfix
firefox35 --- affected
firefox36 --- affected
firefox37 --- affected
firefox-esr31 --- unaffected

People

(Reporter: FlorinMezei, Unassigned)

References

Details

Reproducible with Firefox 34 Beta 11 - BuildID: 20141120192249

Environment: Windows 7 x64, Windows 8 x86, Ubuntu 12.04 x86, Mac OS X 10.9.5

Steps to reproduce:
1. Open Firefox and start typing in the Search field from the toolbar.
2. Press <Tab> to navigate to the first suggestion.

Expected results:
First suggestion is correctly selected. Using Tab will navigate through additional search suggestions.

Actual results:
The "Search for <term> with <engine>" section is selected.
See Also: → 1104142
I reviewed this with Gavin. This isn't a blocker for 34. I have marked 34 as wontfix and tracked for 35+.
How is this not a blocker?

Pressing <tab> to select the first result and navigating through additional suggestions is a common action that is implemented in the old/current search, the address bar and other browsers.

This will lead people that are used the current behavior to search with the wrong search engine. Do you really want to force the people to adapt for FF34 and then change it again in a later release?
I ended up deactivating all search engines but my primary one in order restore the consistent tab behavior, but this workaround is hardly ideal for people who use more than one search engine.
Flags: firefox-backlog? → firefox-backlog+
Making <tab> select the first one-click engine button was an intended change. The down arrow will select the first suggestion.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → INVALID
This is inconsistent with the address bar.

As you state in https://bugzilla.mozilla.org/show_bug.cgi?id=1104971#c9 ctrl+up/down will have the same functionality as tab does in the current implementation. So it will be still possible to change the search engine with ctrl+up/down and tab can be used to autocomplete instead.

Do you have any data to verify that users switch the search engine more often than selecting suggestions? You seem to assign two keyboard shortcuts to the action that is being used less.
(In reply to Greenix from comment #5)

> As you state in https://bugzilla.mozilla.org/show_bug.cgi?id=1104971#c9
> ctrl+up/down will have the same functionality as tab does in the current
> implementation.

Bug 1104971 is no longer the current plan, we will implement bug 1110678 instead.

> Do you have any data to verify that users switch the search engine more
> often than selecting suggestions?

No, we believe users would use a non-default search engine more frequently if doing so was easier.
> No, we believe users would use a non-default search engine more frequently if doing so was easier.

Then maybe you should first make sure that making this easier is worth making another action (autocomplete) harder and introducing inconsistencies at the same time.
Duplicate of this bug: 1108754
Duplicate of this bug: 1123001
I realize that Firefox needs income and wants users to switch away from Google, but making the user interface worse is not a reasonable solution. Is a very bad idea to have two separate behaviors for similar boxes -- the search box should work exactly the same as the URL box, or at least have an about:config setting for advanced users to toggle. I've been using Firefox since it was Mozilla Suite, and I've always been a huge supporter (even starting a Firefox extension Meetup group in the Bay Area).

Power users do not want to lift their hands off the keyboard to press the down arrow or click the mouse. I don't want two separate behaviors for two similar windows, because I alternately press ctrl-k or ctrl-l to do a search depending on whether I want the browser history or not. This is one of FF's strong points over Chrome.

I removed all the search engines, and it still worked in the last version of Firefox, but now when I press tab, the cursor completely leaves the search box and doesn't do anything. At least make it so that when there are no other search engines one can still press tab.

If Firefox does things like this, you are going to alienate your strongest supporters.
People who want to use a different search engine can click on it with the mouse. It is not a common task to switch search engines in Firefox. I've probably only done it three times in 10 years. With those buttons there I would probably click on it with the mouse more frequently, but the tab solution is really unacceptable from a usability standpoint.
Is this still being worked on? I've avoided commenting about it again, because I thought it was being fixed, but now it says "RESOLVED INVALID" at the top. 

I'm confused about the status, and about why this blog post ( https://blog.mozilla.org/ux/2014/11/find-it-faster/ ) was deleted -- many users were complaining about it:

"I hate it! I need it changed back to what I’m used to."

"Clicking or cycling through the list with the arrow keys is slightly laborious"

"Can we restore the old version of the search bar, at least as an option?"

"There are a lot of problems with this new search approach"

"This is another UI change that doesn’t make sense and doesn’t bring joy,"

"I don’t like it…. Now it is harder to use than before, i think it is useless."

"is there an easy way to have old behavior"

"To me it looks like you try really hard to keep users switching from Yahoo"

This issue is making me hate Firefox every time I go to do a search with ctrl-k, because it forces me to change the way I've been using Firefox for 10 years, and it appears to be a selling out of the usability to sponsors. It's bad design to have two input boxes next to each other where tab works for one and you need to move your hand or mouse to get the same behavior on the other. Using arrow keys is very tedious for people who use kinesthetic sense to operate the computer, because it requires moving your hand, and every keyboard has the arrow keys in a different location. Keyboard shortcuts have always been one of Firefox's strong points -- don't ruin this for advanced users.

Analogy: it's like people who use arrow keys in Vim -- they are free to be inefficient if they want, but people who know what is faster will use hjkl. Same with the avoidance of arrow keys when browsing the Web. Tab is like one of the hjkl keys of Firefox search.

So far, I've been able to use about:config to override all of of the UI annoyances that have been borrowed from Chrome over the past few years, but I haven't been able to find out how to get tab working correctly again for the search box. There should at least be a setting to override this. There are other problems within the search box, but I can live with them. The current tab key behavior is critically irritating though.

Sorry for the rant, but this is a terrible decision for the user interface.
(In reply to hostelmarketing from comment #10)
> I realize that Firefox needs income and wants users to switch away from
> Google, but making the user interface worse is not a reasonable solution. Is
> a very bad idea to have two separate behaviors for similar boxes -- the
> search box should work exactly the same as the URL box, or at least have an
> about:config setting for advanced users to toggle. I've been using Firefox
> since it was Mozilla Suite, and I've always been a huge supporter (even
> starting a Firefox extension Meetup group in the Bay Area).
> 
> Power users do not want to lift their hands off the keyboard to press the
> down arrow or click the mouse. I don't want two separate behaviors for two
> similar windows, because I alternately press ctrl-k or ctrl-l to do a search
> depending on whether I want the browser history or not. This is one of FF's
> strong points over Chrome.

Just chiming in to say I agree with this 100%. Every time a new update is released I keep hoping this has been changed/fixed. This has made the Firefox user experience far more frustrating. Even if the default behavior isn't changed, an about:config setting would be most welcome.
This problem needs to be fixed one way or another -- whether it is fixing the behavior or adding a setting in about:config. This kind of thing is ruining Firefox. So far, I've been able to override all of the annoyances (like URL trimming) with about:config, but this one has no fix yet.

Now the deleted blog post where people were complaining about the feature was republished? ( https://blog.mozilla.org/ux/2014/11/find-it-faster/ )

Something is fishy about this whole thing. The feature is inconsistent and makes no sense other than Yahoo's influence. The quality of the interface should not be corrupted on account of Yahoo.
Duplicate of this bug: 1297854
* Behavior should be consistent between the URLbar and search bar.

* In the event that the user has no one-off search engines (indicating they have no desire to use them), is it really more likely that they would want to access Change Search Settings more easily/frequently than the first suggestion?

* Are the users who would use one-off searches really the same ones who are likely to use Tab?  It's more likely that the users who use one-off searches would be more likely to access the searches by clicking.  Tab should be reserved for the power users.

* Tab should be reserved for the most common and consistent usage, i.e. selecting the first suggestion.  This would be consistent with the rest of Firefox and the internet: tab selects the next item.
(In reply to Florian Quèze [:florian] [:flo] from comment #6)
> (In reply to Greenix from comment #5)
>
> > Do you have any data to verify that users switch the search engine more
> > often than selecting suggestions?
> 
> No, we believe users would use a non-default search engine more frequently
> if doing so was easier.

Trying to get inexperienced users to use a new feature through a keyboard shortcut that's unintuitive and inconsistent with the rest of the internet is unlikely to be effective.
You need to log in before you can comment on or make changes to this bug.