Jittery animation after click (WebGL)

RESOLVED INVALID

Status

()

Core
General
RESOLVED INVALID
4 years ago
8 months ago

People

(Reporter: Tobi Reif, Unassigned)

Tracking

33 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:33.0) Gecko/20100101 Firefox/33.0
Build ID: 20141113143407

Steps to reproduce:

The following issue occurs sometimes, in Firefox and Chrome and Safari, but not always (eg it occurs after each click, but not on a different day). I hope you can you can repoduce it.

I also submitted the report to Apple as a Mac OS issue, but I thought perhaps there's something that you guys can improve, or perhaps you can request required changes from the guys implementing the underlying layers (eg OS/driver).

When I load
http://tobireif.com/boomchat_copy_2_for_bugreport/web/
in Firefox/Chrome/Safari, and click on one of the emoticons, the then following animation of WebGL graphics stutters slightly for the first ~0.7 seconds, then becomes smooth and fast as expected.

For testing: When you click the emoticons repeatedly and quickly, the triggers get queued and the animations start in sequence without requiring current clicks. These animations are all smooth. But when you wait for eg the first animation to finish completely and only then click again, the first and second animations are jittery (and each following animation that has been started with a click after waiting for the previous animation to finish). Perhaps the reaction to the click slows the animation down?

Please compare the click-triggered animations with the queue-triggered animations - the issue is barely noticable but still crucial for me. I hope your hardware/software combo allows you to repoduce it.

Info: MacBook Pro, NVIDIA GeForce 9400M 256 MB, Mac OS X 10.9.5.

I hope you can permanently ensure the great animation performance that can be observerd sometimes.



Actual results:

(see desc)


Expected results:

Smooth and highly performant animation.

Updated

4 years ago
Component: Untriaged → Untriaged
Product: Firefox → Core
(Reporter)

Comment 1

3 years ago
Recently I found out that the issue occurs when the MacBook is not plugged in / runs on battery.
Apple says they've fixed it in Yosemite. Will try to test on Yosemite as soon as I can.
Closing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
Moving from Core::Untriaged to Core::General https://bugzilla.mozilla.org/show_bug.cgi?id=1407598
Component: Untriaged → General
You need to log in before you can comment on or make changes to this bug.