SSL-dropdownbox is too small for labels

RESOLVED FIXED in Thunderbird 63.0

Status

Thunderbird
Account Manager
RESOLVED FIXED
4 years ago
8 days ago

People

(Reporter: Elbart, Assigned: Paenglab)

Tracking

unspecified
Thunderbird 63.0
x86_64
Windows 7

Thunderbird Tracking Flags

(thunderbird_esr60 fixed, thunderbird61 wontfix, thunderbird62 fixed, thunderbird63 fixed)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

4 years ago
Created attachment 8526883 [details]
ssl_tb.png

TB 31.2 (auch schon in 24.x)

"Autodetect"[1] wird noch erkennbar mit "Automatisch erke..."[2] übersetzt,
aber "None" wird durch "Keine Verbindung..." nicht sinnvoll dargestellt.

> [1] http://hg.mozilla.org/comm-central/file/default/mail/locales/en-US/chrome/messenger/accountCreation.dtd#l33

> [2] http://hg.mozilla.org/l10n-central/de/file/default/mail/chrome/messenger/accountCreation.dtd#l33
(Reporter)

Updated

4 years ago
Summary: SSL-Dropdownbox in "Konto einrichten"-Dialog ist zu klein → SSL-dropdownbox is too small for labels
Richard, do you have suggestions how to fix this?
Flags: needinfo?(richard.marti)
(Assignee)

Comment 2

4 years ago
It looks like the column width is calculated with the elements of the last row. I changed the outgoing_label to a textbox and the width was enough for showing the full "Automatisch erkennen". But this would be a hack because it is only a label.

A other possibility and also somehow a hack would be to make the label longer. Here on Win7 <!ENTITY outgoing.label "Postausgang-Server:                      "> made also "Keine Verbindungssicherheit" uncropped.

Not the cleanest way but it works and I'm not a XUL specialist. Maybe Neil could help.
Flags: needinfo?(richard.marti)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Nit sure if I picked the right component, but this is not a localization bug, it's a product bug.
Component: de / German → Account Manager
Product: Mozilla Localizations → Thunderbird

Comment 4

2 months ago
Can you try setting some of the values of 'sizetopopup' attribute on the parent menulist?
https://developer.mozilla.org/en-US/docs/Mozilla/Tech/XUL/Attribute/sizetopopup
Otherwise we would have to make the dialog even wider than it already is.
Flags: needinfo?(richard.marti)
(Assignee)

Comment 5

2 months ago
Created attachment 8982796 [details] [diff] [review]
Bug1103040.patch

This one fixed it for me. The menulist had a width: 10em; which fixed this width. I changed it to min-width to let it grow when needed.

I also removed the #incoming_username rule because it isn't needed and always wider than this because this column with the server names has the flex="1".
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Flags: needinfo?(richard.marti)
Attachment #8982796 - Flags: review?(acelists)
(Assignee)

Comment 6

14 days ago
Aceman, gentle review ping.

Comment 7

14 days ago
Comment on attachment 8982796 [details] [diff] [review]
Bug1103040.patch

Review of attachment 8982796 [details] [diff] [review]:
-----------------------------------------------------------------

No, this enlarges the dialog to however long the translator sends us a string. That is not acceptable.
Why didn't sizetopopup="none" work?
Attachment #8982796 - Flags: review?(acelists)
(Assignee)

Comment 8

14 days ago
(In reply to :aceman from comment #7)
> Review of attachment 8982796 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> No, this enlarges the dialog to however long the translator sends us a
> string. That is not acceptable.
> Why didn't sizetopopup="none" work?

Only sizetopopup="none" doesn't help because the width is fixed in CSS to 10em. A combination with both, my patch and sizetopopup="none", would work, but then the dialog width jumps depending of the selected entry. Is this what you want?
Flags: needinfo?(acelists)

Comment 9

14 days ago
(In reply to Richard Marti (:Paenglab) from comment #8)
> (In reply to :aceman from comment #7)
> > Review of attachment 8982796 [details] [diff] [review]:
> > -----------------------------------------------------------------
> > 
> > No, this enlarges the dialog to however long the translator sends us a
> > string. That is not acceptable.
> > Why didn't sizetopopup="none" work?
> 
> Only sizetopopup="none" doesn't help because the width is fixed in CSS to
> 10em.

Why not? What is wrong with that? If we limit the 'button' to 10em but the menupopup is unlimited in width using sizetopopup=none, is that not enough?
Or did you plan to show the full text also when the menupopup is closed (thus on the menulist)?

> A combination with both, my patch and sizetopopup="none", would work,
> but then the dialog width jumps depending of the selected entry. Is this
> what you want?

I do not want to make the dialog wider, at least not unlimited, as with the current patch. We can't allow it to grow to 2000px if the translator puts some long string there.
Flags: needinfo?(acelists)
(Assignee)

Comment 10

14 days ago
Created attachment 8990589 [details] [diff] [review]
Bug1103040.patch

Now I've got what you meant.

To make the dialog again a bit smaller we could do the same to incoming_authMethod and outgoing_authMethod.
Attachment #8982796 - Attachment is obsolete: true
Attachment #8990589 - Flags: review?(acelists)
(Assignee)

Comment 11

14 days ago
But this would crop the text in the menulist also in en_US.

Comment 12

13 days ago
So maybe you could up those to 15em, the important fact is that the size is limited and not freely expanded to the text.
(Assignee)

Comment 13

12 days ago
Created attachment 8990797 [details] [diff] [review]
Bug1103040.patch

How about this? With 15em width.
Attachment #8990589 - Attachment is obsolete: true
Attachment #8990589 - Flags: review?(acelists)
Attachment #8990797 - Flags: review?(acelists)

Comment 14

12 days ago
Comment on attachment 8990797 [details] [diff] [review]
Bug1103040.patch

Review of attachment 8990797 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks, I'm fine with this. The dialog is about 870px wide for me (even with a long string in the menupopup).
It is sad that when the values in the menupopup are shorter, they are not at least as wide as the menulist button. There seems to be no value for sizetopopup to achieve this. Value of "pref" does not seem to do that.
Attachment #8990797 - Flags: review?(acelists) → review+
(Assignee)

Updated

12 days ago
Keywords: checkin-needed

Comment 15

11 days ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/09c880971634
Allow the SSL menu popup to expand when needed. r=aceman
Status: ASSIGNED → RESOLVED
Last Resolved: 11 days ago
Keywords: checkin-needed
Resolution: --- → FIXED

Comment 16

11 days ago
Uplift?
Target Milestone: --- → Thunderbird 63.0

Comment 17

8 days ago
I'm asking again: Uplift?
Flags: needinfo?(richard.marti)
(Assignee)

Comment 18

8 days ago
Comment on attachment 8990797 [details] [diff] [review]
Bug1103040.patch

Not tried but it should apply.
Flags: needinfo?(richard.marti)
Attachment #8990797 - Flags: approval-comm-esr60?
Attachment #8990797 - Flags: approval-comm-beta?

Updated

8 days ago
Attachment #8990797 - Flags: approval-comm-esr60?
Attachment #8990797 - Flags: approval-comm-esr60+
Attachment #8990797 - Flags: approval-comm-beta?
Attachment #8990797 - Flags: approval-comm-beta+

Comment 19

8 days ago
Beta (TB 62):
https://hg.mozilla.org/releases/comm-beta/rev/823bafa3d2f10b5aa9cc05493e593face3fede01
status-thunderbird61: --- → wontfix
status-thunderbird62: --- → fixed
status-thunderbird63: --- → fixed
status-thunderbird_esr60: --- → affected
You need to log in before you can comment on or make changes to this bug.