[Camera] Receiving a call while recording a video, causes the recorded video to be deleted

RESOLVED DUPLICATE of bug 1088452

Status

Firefox OS
Gaia::Camera
RESOLVED DUPLICATE of bug 1088452
3 years ago
3 years ago

People

(Reporter: FredM, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected, b2g-v2.2 unaffected)

Details

(Whiteboard: [2.1-exploratory-3], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8526904 [details]
logcat_20141121_1009.txt

Description:
While recording a video if a User receives a call, the recorded video is deleted
   
Repro Steps:
1) Update a Flame device to BuildID: 20141121001202
2) Launch "Camera"
3) Record a video
4) While recording, receive a call (either answer or reject the call)
5) Go back to the camera and play the recorded video
  
Actual:
The recorded video is deleted
  
Expected: 
The recorded video is not deleted
  
Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141121001202
Gaia: 6c739275e963465658c18c7a9ebaa48cbe927d34
Gecko: 9bfc7a166a94
Version: 34.0 
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
  
  
Repro frequency: 100%
See attached: video clip & logcat: http://youtu.be/N_oLzpB9s-c
Flags: needinfo?(dharris)
(Reporter)

Comment 1

3 years ago
This issue does NOT repro on Flame 2.2 (319mb)(Kitkat Base)(Shallow Flash) and Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)

Result:
While recording a video if a User receives a call, the recorded video is NOT deleted

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat Base)(Shallow Flash)
Build ID: 20141121040204
Gaia: 25388c6bce932657ebf93adedf31881bfaf88c15
Gecko: 3366c0fcf9c2
Version: 36.0a1 
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

-------------------------------------------------------------------------------------------------------

Environmental Variables:
Device: Flame 2.0 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141121000203
Gaia: 626d4d11a8c7e55022c1f364abb72ea340e2f1e7
Gecko: 74a294e72d0a
Version: 32.0 
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
[Blocking Requested - why for this release]:

If the user is recording a video and they receive a call, the video should be stopped and saved, but instead becomes corrupt. This is a regression and poor UX. Nominating to block 2.1
blocking-b2g: --- → 2.1?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(dharris)
Keywords: regressionwindow-wanted
This appears to be a dupe of bug 1088452
Status: NEW → RESOLVED
blocking-b2g: 2.1? → ---
Last Resolved: 3 years ago
QA Whiteboard: [QAnalyst-Triage+]
Resolution: --- → DUPLICATE
Duplicate of bug: 1088452
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
Flags: needinfo?(jmercado)
You need to log in before you can comment on or make changes to this bug.