Pressing the home button on the home screen instantly returns to the top of the home screen instead of smoothly scrolling

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Homescreen
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: mikehenrty, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [systemsfe])

+++ This bug was initially created as a clone of Bug #1088700 +++

Pressing the home button on the home screen should (and used to, about a week ago and all times prior) smoothly scroll to the top of the screen. It now instantly jumps to the top of the screen.

I believe this is a platform regression. It could be that we need to alter something in the homescreen code.
:kip, you seemed to know what was going on in bug 1088700. Any idea why this might have regressed again? The code in question that invokes the smooth scrolling is [1].

1.) https://github.com/mozilla-b2g/gaia/blob/74333400721627197694a3d722527a5a38cf8848/apps/verticalhome/js/app.js#L262
Flags: needinfo?(kgilbert)
The line to scroll to the top is correct for the latest Gecko.  If used on an earlier Gecko, it would result in instantly scrolling to the top.

Bug 1045754 updated the syntax to match changes to the CSSOM-View specification at w3.org.  What is currently on the home screen in GAIA matches the latest CSSOM-View specification and the current Gecko implementation.

A different syntax would be required for Gecko versions that did not include Bug 1045754's patches.

Please advise if it is something deeper -- I'd be glad to investigate further.
Flags: needinfo?(kgilbert)
Yeah, I was seeing this but had assumed it was because I hadn't updated gecko in a while. After updating my flame to the latest OTA I'm still seeing this.

Reproduced on: Gaia-Rev        c5bad6d78c5fe168e3bb894fc5cb70902c9b19b1
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/87d4d6d5facc
Build-ID        20141121160202
Version         36.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  39
FW-Date         Thu Oct 16 18:19:14 CST 2014
Bootloader      L1TC00011880


I'll try to dig in a bit, but also ni? on Kip again because it feels like there could be a platform issue here.

We should also see if there's a way to test this from the gaia side, but I'm not sure if we can easily do that.
Flags: needinfo?(kgilbert)
I have built and flashed my flame, resulting in smooth scrolling on the home screen:

Gaia-rev: e5d666d6f62480ced56c6d9352f5e12befb5a862
Gecko-Rev: https://hg.mozilla.org/mozilla-central/rev/5c4d07e2199e

Are you still seeing the instant scroll, or perhaps one of the backouts in this Gecko revision could have had an effect?
Please advise if you are still seeing the smooth scrolling disabled with Gecko-Rev > https://hg.mozilla.org/mozilla-central/rev/5c4d07e2199e
Flags: needinfo?(kgilbert) → needinfo?(kgrandon)

Comment 6

4 years ago
This is fixed for me using central and gaia master from yesterday afternoon.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(kgrandon)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.