Closed Bug 1103132 Opened 10 years ago Closed 6 years ago

Link to custom element definition from inspector

Categories

(DevTools :: Inspector, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1443923

People

(Reporter: bgrins, Unassigned)

Details

It'd be nice if there was a button near a custom element in the markup view that would navigate you to the place where that custom element was defined in JS.
Inspector bug triage. Filter on CLIMBING SHOES.

Brian: Assuming we keep this bug, could we add some more information to make it easier to be picked by someone?
Severity: normal → enhancement
Flags: needinfo?(bgrinstead)
Priority: -- → P3
(In reply to Julian Descottes [:jdescottes] from comment #1)
> Inspector bug triage. Filter on CLIMBING SHOES.
> 
> Brian: Assuming we keep this bug, could we add some more information to make
> it easier to be picked by someone?

I think this is talking about Custom Elements, which hasn't landed (Bug 889230 although it can be tested by flipping dom.webcomponents.enabled on).  I think it could still be a nice feature but it's blocked on that work and I also haven't investigated what platform APIs are needed to go to the definition.  Feel free to wontfix it if you'd like and it could be reopened later, or deprioritize.
Flags: needinfo?(bgrinstead)
Product: Firefox → DevTools
Looks like bgrins filed the same bug twice :P
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.