Cannot connect WebIDE to Flame with e10s disabled

RESOLVED INVALID

Status

DevTools
WebIDE
RESOLVED INVALID
4 years ago
12 days ago

People

(Reporter: _6a68, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
STR:
1. flash v188-1 base image onto Flame
2. flash gaia master onto Flame with `DEVICE_DEBUG=1 NOFTU=1 make reset-gaia`
3. open WebIDE
4. select 'Firefox OS (flame)' in the 'devices' dropdown at top right of the WebIDE window

Expected: Debugger connects successfully
Actual: Debugger never connects.

I was having intermittent connection issues last week, but currently can't connect to my device at all.

I do see an error trace in the `adb logcat` output when I select the 'Firefox OS (flame)' option in the dropdown:

W/GeckoConsole( 4165): [JavaScript Error: "error occurred while processing 'listTabs: TypeError: browser.getTabBrowser is not a function
W/GeckoConsole( 4165): Stack: BrowserTabList.prototype.getList@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/actors/webbrowser.js:326:1
W/GeckoConsole( 4165): RootActor.prototype.onListTabs@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/actors/root.js:275:12
W/GeckoConsole( 4165): DSC_onPacket@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/server/main.js:1485:15
W/GeckoConsole( 4165): DebuggerTransport.prototype._onJSONObjectReady/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/transport/transport.js:461:9
W/GeckoConsole( 4165): makeInfallible/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/DevToolsUtils.js:83:14
W/GeckoConsole( 4165): makeInfallible/<@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/DevToolsUtils.js:83:14
W/GeckoConsole( 4165): Line: 326, column: 0" {file: "resource://gre/modules/commonjs/toolkit/l

I realize it looks like the log lines were truncated, but I didn't do it--that's exactly what I saw in the terminal output.
(Reporter)

Updated

4 years ago
Summary: Cannot connect WebIDE to Flame after flashing gaia → Cannot connect WebIDE to Flame
(Reporter)

Updated

4 years ago
Summary: Cannot connect WebIDE to Flame → Cannot connect WebIDE to Flame with e10s disabled
(Reporter)

Comment 1

4 years ago
OK, update: I was not able to connect *with e10s disabled*.

I re-enabled e10s, then tried flashing gaia and reconnecting WebIDE. It successfully reconnected 5/5 times.

If WebIDE isn't intended to be used without e10s, then feel free to close as invalid :-)
(Reporter)

Comment 2

4 years ago
I also forgot to mention that I'm using the latest nightly (currently 36.0a1 (2014-11-21)).
(Reporter)

Comment 3

4 years ago
Trying once more from scratch, I'm not able to reproduce the bug.

1. flash v188-1 onto device
2. using Mozilla-TWQA tool, shallow flash ("gecko + gaia") mozilla-central Engineer build onto device
3. flash up-to-date github gaia master onto device via `DEVICE_DEBUG=1 NOFTU=1 make reset-gaia`
4. open webide, attempt to connect to flame

With e10s disabled: WebIDE connects.

Try flashing (step 3) again, leaving WebIDE and USB cable connected. WebIDE is able to reconnect via the dropdown 3/3 tries.

Closing for now, I guess this is a mystery for the ages ¯\_(ツ)_/¯
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID

Updated

12 days ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.