If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

N620 crash [@ nsHttpConnection::Init ]

VERIFIED DUPLICATE of bug 106097

Status

()

Core
Networking: HTTP
P1
critical
VERIFIED DUPLICATE of bug 106097
16 years ago
15 years ago

People

(Reporter: Jan Carpenter, Assigned: Darin Fisher)

Tracking

({crash, topcrash, topembed})

Trunk
mozilla0.9.7
x86
Windows 98
crash, topcrash, topembed
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

16 years ago
This bug is a topcrasher for N620.

 Count   Offset    Real Signature
[ 172   nsHttpConnection::Init 7d088351 - nsHttpConnection::Init ]
[ 10   nsHttpConnection::Init ea4147eb - nsHttpConnection::Init ]
[ 2   nsHttpConnection::Init 275d180e - nsHttpConnection::Init ]
 
     Crash date range: 2001-11-04 to 2001-11-14
     Min/Max Seconds since last crash: 15 - 193335
     Min/Max Runtime: 24 - 550809
     Keyword List : espn(9), log(4), mail(5), msn(5), netscape(10), shut(6),  
     Count   Platform List 
     123   Windows 98 4.90 build 73010104
     41   Windows 98 4.10 build 67766446
     19   Windows 98 4.10 build 67766222
     1   Windows 95 4.0 build 67306684
 
     Count   Build Id List 
     184   2001102218
 
     No of Unique Users       167
 
 Stack trace(Frame) 

	 nsHttpConnection::Init
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHttpConnection.cpp 
line 89] 
	 nsHttpHandler::InitiateTransaction_Locked
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHttpHandler.cpp  line 724] 
	 nsHttpHandler::ProcessTransactionQ
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHttpHandler.cpp  line 646] 
	 nsHttpHandler::ReclaimConnection
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHttpHandler.cpp  line 429] 
	 NECKO.DLL + 0x3887c (0x6085887c)  
	 nsFileChannel::AddRef
[d:\builds\seamonkey\mozilla\netwerk\protocol\file\src\nsFileChannel.cpp  line 99] 
	 nsSocketIS::AddRef  
	 0x85107d8b   
 
     (37987187)	URL: www.espn.com
     (37987187)	Comments: again trying to visit espn.com like i do everyday
     (37987101)	URL: www.espn.com
     (37987101)	Comments: trying to visit espn.com
     (37986607)	Comments: doing research
     (37981135)	URL: NECKO.BLL
     (37981135)	Comments: I was attempting to log onto ESPN.com
     (37979320)	Comments: opened up two browsers and then they got an error
     (37978430)	URL: www.msnbc.com
     (37977158)	URL: espn.go.com
     (37972575)	URL: on netscape  "home " home.com
     (37972575)	Comments: Trying to down load article on "Second rercorder found"
     (37970505)	URL: netscape.com
     (37960854)	Comments: changing colors for links in a webpage
     (37949219)	Comments: surfing the internet
     (37944764)	Comments: I had just clicked on the sign of cancer from the netscape
horoscope web site.
     (37930371)	URL: espn.com
     (37930371)	Comments: Once again.  I tried to go to ESPN and Netscape shut down.  This
is the forth time this happened in the last week.  Is this a Netscape problem or
a problem with the ESPN website?
     (37929862)	URL: www.walmart.com
     (37929862)	Comments: jumping from k-mart.com to walmart.com
     (37928123)	URL: msnbc.com
     (37928123)	Comments: trying to open a link
     (37925007)	Comments: I was trying to access nascar.com when this message occurred.I had
just finished checking my email.
     (37914753)	URL: espn.com
     (37905186)	URL: netscape home and https.//www.transunion.com and mailbox
     (37905186)	Comments: Printing information from a web page.
     (37898754)	URL: www.monster.com
     (37898754)	Comments: Trying to open "My Monster"
     (37887927)	URL: netscape.com
     (37887927)	Comments: accessing a netscape banner ad
     (37887473)	Comments: I was trying to look at a video using Windows Media Player. It
always crashes every time I use the Window Media Player. The other players work
fine.
     (37880205)	Comments: just browsing
     (37872103)	URL: espn.com
     (37870013)	Comments: trying to select music channel
     (37867781)	Comments: I was running web page when the error occured.
     (37865796)	Comments: nothing i just try again are somtimes i get mad
     (37864310)	Comments: browsing
     (37861817)	URL: www.nascar.com
     (37861817)	Comments: clicked nascar.com in my bookmarks and browser failed
     (37853043)	Comments: very slow to start any window
     (37852543)	Comments: updating my auctions on MSN and bringing up my MSN webpage to link
to the Lycos auction.
     (37850692)	URL: espn.go.com
     (37842135)	Comments: Trying to log onto Nascars Web Site?????
     (37841344)	URL: nascar.com
     (37841344)	Comments: trying to go to nascar.com
     (37839265)	Comments: click on music on the home page
     (37838994)	URL: espn.go.com
     (37838426)	Comments: customizing settings 
     (37837606)	Comments: I was doing what I will never do again; reading the CNN links from
the Netscape main page.  This always happens when I try to read anything from
the Netscape site  so I will go to other places to read the news.
     (37830851)	URL: www.espn.com
     (37830851)	Comments: loading page
     (37827586)	Comments: trying to view the india tv.com
     (37824792)	URL: http://www.tat-2-express.com
     (37824551)	Comments: You SUCK!!!!!!!!!!!!!!!!!!!!!!!!!!!
     (37819503)	URL: http://www.espn.com
     (37819503)	Comments: Openning espn.com homepage
     (37818452)	URL: Clickondetroit.com
     (37818452)	Comments: Changeing my home page address.
     (37814994)	URL: http://tv.eaarthcam.com
     (37814387)	URL: www.msn.com
     (37811972)	Comments: Looking at the preferences file
     (37811128)	Comments: I was reading my email.
     (37810211)	URL: java.sun.com
     (37808323)	URL: espn.com
     (37808323)	Comments: Take three.  Typed espn.com  and netscape shut down
     (37804816)	URL: www.msn.com
     (37804816)	Comments: was on MSN site
     (37802888)	URL: http://www.msnbc.com
     (37799649)	Comments: I was searching for stores that sell winter coats
     (37791400)	URL: www.ebay.com
     (37790101)	URL: www.ebay.com
     (37790101)	Comments: looking at items in an ebay online store
     (37776639)	URL: www.blackplanet.com
     (37773074)	URL: Www.dell
     (37771546)	Comments: trying  to launch a java applet
     (37765339)	URL: sports.netscape.com/sports/main.tmpl
     (37765339)	Comments: tried to access sports and crashed Netscp6 with msg'performed
illegal operation & will be shut down.'I'm at home behind a firewall (router).
     (37764817)	Comments: going into wal-mart.com
     (37754316)	Comments: Was using netscape mail when it closed one me..
     (37754190)	URL: www.talknet.de
     (37754190)	Comments: Internet explorer
     (37753917)	URL: espn.com
     (37753917)	Comments: Twice in a row.  I typed espn.com and netscape shut down.  A
little help here?
     (37753645)	URL: espn.com
     (37753645)	Comments: typed in espn.com and netscape6.2 shut down.  Simple task what
gives?    Bring back 4.76
     (37731097)	Comments: I was at:  www.launch.com and it just closed down.
     (37729819)	Comments: I was reading my e-mail and deleting those that I no longer desired.
     (37725719)	Comments: accessing msnbc.com technology page
     (37724218)	Comments: i was on the yellow pages screen and clicked on the netscape home
. a warning came on screen that the program had performed an illegal operation
     (37724024)	Comments: opened up  then shut immediately down
     (37722901)	URL: www.commissioner.com
     (37715864)	URL: netscape.com
     (37715864)	Comments: search
     (37715442)	Comments: going from netscape's front page to the sports section then to nba
and then to the title story there
     (37715419)	Comments: I was switching from the search page to housecall antivirus when
system crashed
     (37706543)	Comments: I was reading a message and clicked on another one to open it  and
ns crashed.
     (37675908)	URL: http://www.espn.com
     (37675908)	Comments: Going to the ESPN home page
     (37673208)	Comments: The Quality Feedback Agent may have come up because I didn't enter
the master password soon enough to get an error-free download of my e-mail. 
Otherwise I have no idea why the damn thing came up!
     (37673136)	URL: www.msnbc.com
     (37673136)	Comments: going to the sports section.
     (37672272)	Comments: going to another page within a site.
     (37669954)	URL: www.blackplanet.com
     (37660148)	URL: www.nascar.com
     (37660148)	Comments: go to site
     (37655948)	Comments: Had just exited help menu and was attempting to exit open
preferences window
     (37628218)	URL: http://www.msnbc.com
     (37628218)	Comments: I was going to a new news link within MSNBC on the net.
     (37617968)	URL: www.msn.com
     (37617968)	Comments: general default error
     (37609692)	Comments: opening a msn web page
     (37596768)	Comments: i was trying to go to a site for  an astrological chart. i was 
refused.
(Reporter)

Updated

16 years ago
Keywords: crash, topcrash

Updated

16 years ago
Severity: normal → critical

Comment 1

16 years ago
 - nsHttpConnection::Init 7d088351 BBID: 37837606
I was doing what I will never do again; reading the CNN links from the Netscape
main page. This always happens when I try to read anything from the Netscape
site so I will go to other places to read the news.
Build: 2001102218 Crash Date: 2001-11-10
33628 sec. Using CNN page from Netscape running on Windows 98 4.10 build
67766446 src_file
d:/builds/seamonkey/mozilla/netwerk/protocol/http/src/nsHttpConnection.cpp line 89

Comment 2

16 years ago
here is another report out of the tb database...  couldn't repro this one either..

http://semo.net
User Comments clicked on a link to cnn to see how attacks in Jordan were foiled,

http://semo.net/sendoff.asp?Name=CNN&URL=http://www.cnn.com/2001/WORLD/meast/11/18/inv.jordan.intelligence/index.html

 not sure what came up, but it said that netscape had performed an illegal
operation & would be shut down. 
Build ID 2001102218
Product ID Netscape6.20
Platform
Operating System Win32
Module
Trigger Reason Access violation
Stack Trace
nsHttpConnection::Init
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHttpConnection.cpp,
line 89]
nsHttpHandler::InitiateTransaction_Locked
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHttpHandler.cpp, line 724]
nsHttpHandler::ProcessTransactionQ
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHttpHandler.cpp, line 646]
nsHttpHandler::ReclaimConnection
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHttpHandler.cpp, line 429]
NECKO.DLL + 0x3887c (0x6085887c)
nsFileChannel::AddRef
[d:\builds\seamonkey\mozilla\netwerk\protocol\file\src\nsFileChannel.cpp, line 99]
nsSocketIS::AddRef
0x85107d8b 
(Assignee)

Comment 3

16 years ago
-> investigating for 0.9.7
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → mozilla0.9.7
(Assignee)

Comment 4

16 years ago
the stack traces in this bug look pretty bunk... nsSocketIS::AddRef cannot
possibly invoke nsFileChannel::AddRef :(
(Assignee)

Comment 5

16 years ago
if this is only happening on the 0.9.4 branch, then i may know what the problem
is.  my patch for bug 83526 included a fix for a race condition in
nsHttpHandler::ProcessTransactionQ.  this race condition could cause a crash,
which may actually be this crash.  this is the patch:

http://bugzilla.mozilla.org/attachment.cgi?id=47292&action=view

note that this patch is actually quite large, so we probably don't want it on
the 0.9.4 branch.  it may be difficult to extract the relavent portions needed
to avoid the crash, but the resulting patch probably won't look that much like
the one on the trunk.
(Assignee)

Comment 6

16 years ago
s/but the resulting/so the resulting/
(Assignee)

Comment 7

16 years ago
looking through

http://ftp.mozilla.org/pub/data/crash-data/detailed-crash-analysis-all.html

and it seems as though this is not happening on the trunk.  so, considering that 
the patch for bug 83526 represents the only real difference between the relavent
code on the trunk and the branch (provided of course if the stack trace can be
trusted), i think we need to land some part of that patch on the 0.9.4 branch.
Keywords: edt0.9.4
(Assignee)

Updated

16 years ago
Keywords: topembed

Comment 8

16 years ago
jan, are we seeing this 0.9.5 talkback data?

darin, can you suggest some specific (if any, maybe just HTTP surfing is enough)
tests for verification on the trunk here?
(Assignee)

Comment 9

16 years ago
i have absolutely no idea how to reproduce this crash.  i have never encountered
it myself.

also, note that the stack trace is extremely questionable... so, this is
probably due to someone scrubbing memory somewhere... making this a very
difficult bug to track down.

Comment 10

16 years ago
while this is a top crasher, given that 
1. the patch seems to be large (and in my assessment too risky for 0.9.4)
2. our MTBF is reasonable enough,
I am marking this bug as edt0.9.4-
If you feel otherwise, please present counterarguments
Keywords: edt0.9.4 → edt0.9.4-
(Assignee)

Comment 11

16 years ago

*** This bug has been marked as a duplicate of 106097 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 12

15 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
QA Contact: tever → junruh
Crash Signature: [@ nsHttpConnection::Init ]
You need to log in before you can comment on or make changes to this bug.