[Music] Music will not begin playing when pressing the play button on a bluetooth headset

VERIFIED FIXED

Status

defect
VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: AdamA, Assigned: dkuo)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: [2.2-Daily-Testing], URL)

Attachments

(3 attachments)

Posted file logcat
Description:
After connecting a bluetooth headset and entering the music app songs will not begin playing when pressing the play button on the headset. if music is already playing the music will pause and play when this button is pressed.

Repro Steps:
1) Update a Flame to 20141121040204
2) Connect a pair of bluetooth headphones
3) Enter music app
4) Press play button on bluetooth headset
5) Observe music app

Actual:
Music does not begin playing when pressing play button on bluetooth headset

Expected:
It is expected that music will begin playing when pressing play button on bluetooth headset

Environmental Variables:
Device: Flame 2.2 (Shallow flash)(319mb)
Build ID: 20141121040204
Gaia: 25388c6bce932657ebf93adedf31881bfaf88c15
Gecko: 3366c0fcf9c2
Version: 36.0a1 (2.2)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Repro frequency: 5/5
See attached: video clip(http://youtu.be/QeihOL3paVM), logcat

-------------------------------------------------------------------------------------------------
This issue occurs on the previous 2.2 Flame.

Environmental Variables:
Device: Flame 2.2 (Shallow Flash)(319mb)
Build ID: 20141120040205
Gaia: 1abe09b4925547699dfdb2d358aed019137c3aa6
Gecko: 6ce1b906c690
Version: 36.0a1 (2.2)
Firmware Version: v188
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Result:
Music does not begin playing when pressing play button on bluetooth headset

-------------------------------------------------------------------------------------------------
This issue does not occur in 2.1 Flame.

Environmental Variables:
Device: Flame 2.1 (319mb)(Kitkat Base)(Shallow Flash)
BuildID: 20141121001202
Gaia: 6c739275e963465658c18c7a9ebaa48cbe927d34
Gecko: 9bfc7a166a94
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Result:
Music begins playing when pressing play button on bluetooth headset
(Reporter)

Updated

5 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Functional regression of a core feature.

Requesting a window.
blocking-b2g: --- → 2.2?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: ckreinbring
Regression window
Last working
BuildID: 20141106045123
Gaia: 068b9711277b06c7d633517f9e1fcb5624bb39b3
Gecko: 0c66a9fd9085
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First broken
BuildID: 20141106122022
Gaia: 1b974ce130eed3988ff5d012c7bd8431c4aba93b
Gecko: 678dd5860cce
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Working Gaia / Broken Gecko = No repro
Gaia: 068b9711277b06c7d633517f9e1fcb5624bb39b3
Gecko: 678dd5860cce
Broken Gaia / Working Gecko = Repro
Gaia: 1b974ce130eed3988ff5d012c7bd8431c4aba93b
Gecko: 0c66a9fd9085
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/068b9711277b06c7d633517f9e1fcb5624bb39b3...1b974ce130eed3988ff5d012c7bd8431c4aba93b

B2G Inbound
Last working
BuildID: 20141106010822
Gaia: 0f93196939e02a559ed23ca4ade6301d3bc9a7de
Gecko: d0177443f822
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

First broken
BuildID: 20141106021323
Gaia: f3bb9e92ef540aeeb464ecb801dd867c42072cda
Gecko: e08fd25dd775
Platform Version: 36.0a1
Firmware Version: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Working Gaia / Broken Gecko = No repro
Gaia: 0f93196939e02a559ed23ca4ade6301d3bc9a7de
Gecko: e08fd25dd775
Broken Gaia / Working Gecko = Repro
Gaia: f3bb9e92ef540aeeb464ecb801dd867c42072cda
Gecko: d0177443f822
Gaia pushlog: https://github.com/mozilla-b2g/gaia/compare/0f93196939e02a559ed23ca4ade6301d3bc9a7de...f3bb9e92ef540aeeb464ecb801dd867c42072cda
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Broken by Bug 1055043 - Dominic can you take a look please.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(dkuo)
(Assignee)

Comment 4

5 years ago
Will take a look.
Assignee: nobody → dkuo

Comment 5

4 years ago
Blocking Reason: Regression
blocking-b2g: 2.2? → 2.2+
(Assignee)

Comment 6

4 years ago
Posted file patch
Caused by the music refactoring(bug 1055043) and this should fix it.
Flags: needinfo?(dkuo)
Attachment #8544412 - Flags: review?(squibblyflabbetydoo)
(Assignee)

Updated

4 years ago
Depends on: 1055043
Comment on attachment 8544412 [details] [review]
patch

rs=me
Attachment #8544412 - Flags: review?(squibblyflabbetydoo) → review+
(Assignee)

Comment 8

4 years ago
Thanks Jim!

master: https://github.com/mozilla-b2g/gaia/commit/0c56746f0399a2ee6302a6b556d9a45b3c4cd509
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
This bug has been verified as "pass" on latest build of Flame 2.2 & Nexus5 2.2 by STR in comment 0.

Actually result: It is expected that music will begin playing when pressing play button on bluetooth headset
.
Reproduce rate: 0/10
See attachment: Flame_V2.2_Verify1.3gp

Device: Flame 2.2 (pass):
Build ID               20150714162501
Gaia Revision          84d0c76370dcd3d25813b00de55194730884355b
Gaia Date              2015-07-09 13:09:14
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a5db6d9850f6
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150714.200955
Firmware Date          Tue Jul 14 20:10:07 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus5 2.2(pass)
Build ID               20150714002501
Gaia Revision          84d0c76370dcd3d25813b00de55194730884355b
Gaia Date              2015-07-09 13:09:14
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/a5db6d9850f6
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150714.042449
Firmware Date          Tue Jul 14 04:25:08 EDT 2015
Bootloader             HHZ12f
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
You need to log in before you can comment on or make changes to this bug.