Closed Bug 1103255 Opened 7 years ago Closed 7 years ago

[E10S] Text Input does not work with Flash Player with E10S Enabled

Categories

(Core :: Plug-ins, defect)

36 Branch
x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
e10s m4+ ---

People

(Reporter: jeclark, Assigned: handyman)

References

Details

Attachments

(1 file)

1.95 KB, application/x-shockwave-flash
Details
Attached file select_para.swf
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.65 Safari/537.36

Steps to reproduce:

Using Firefox Nightly 36.0a1 (2014-11-21) on MacOS 10.9.5: 
Drag the attached SWF into the browser
Click in the big text box at the bottom
Type some stuff


Actual results:

Nothing Happens


Expected results:

Keyboard input should work as expected in a textfield.
Blocks: e10s
Duplicate of this bug: 1103871
Component: Untriaged → Plug-ins
Product: Firefox → Core
Is this a regression?
tracking-e10s: --- → ?
I expect text input currently doesn't work in *any* plugin in e10s mode on the Mac.  See bug 1044182.

We're currently working on a fix for this (and other problems) at bug 1092630.  But the latest patch there isn't yet ready for prime time -- after it's applied, text input doesn't work in Flash (and other plugins) in *either* e10s more or non-e10s mode.

See particularly bug 1092630 comment #37.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → davidp99
This bug is now fixed with the latest patch in bug 1092630.  This bug will close when that one lands.
Running OSX 10.9.5, this is WFM since bug 1092630 landed.  There is still an issue, documented in bug 1110884 about OSX 10.6/10.7.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.