Closed Bug 1103286 Opened 5 years ago Closed 7 months ago

Test rendering is slightly off, for "object-position" rounding edge-cases with SVG-as-an-image in <embed> & <object>

Categories

(Core :: Layout: Images, Video, and HTML Frames, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 608812

People

(Reporter: dholbert, Assigned: dholbert)

References

Details

In bug 1098417, I'm adding some reftests for pixel-rounding behavior with odd "object-position" values.  (The reference cases have the same <position> values, but for "background-position"; basically, the tests just assert that we're consistent.)

We're slightly off in the testcases that use SVG with <embed> and <object>. (off by 1px, in just one of the test-sections)  The tests with SVG in <img> and <video poster> work correctly, though.

I believe this is because we use nsSubdocumentFrame for the <embed>/<object> testcases, and bug 1098417 isn't adding anchor-point support in nsSubdocumentFrame.  So we aren't (yet) getting the 'object-position'-determined anchor point to be pixel-aligned, with SVG content in <embed> & <object>. (I might fix that in this bug here.)

In any case, more info to come; I'm partly filing this bug now so that I've got a bug number that I can use in a "fuzzy" annotation when I land these tests.
(In reply to Daniel Holbert [:dholbert] from comment #0)
> We're slightly off in the testcases that use SVG with <embed> and <object>.
> (off by 1px, in just one of the test-sections)

(It's actually more than off-by-1px. If I add an *additional* patch to use "shape-rendering: crispEdges" to the SVG image files in question [as I'd done locally, when I filed this bug], then it reduces to a 1px offset between test & reference. But that crispEdges change shouldn't be necessary so I'm leaning against that change for the moment; and as a result, these tests have a broader fuzzy region. So, I've just labeled them as "fails" instead of fuzzy, which has the benefit of also letting us discover if we fix them.)
See Also: → 1463827
Product: Core → Core Graveyard
Product: Core Graveyard → Core
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 608812
You need to log in before you can comment on or make changes to this bug.