Closed Bug 1103314 Opened 7 years ago Closed 7 years ago

Clarify label of "Remove All Cookies" button to indicate whether it removes all cookies or just removes the cookies shown

Categories

(Firefox :: Preferences, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 37

People

(Reporter: jidanni, Assigned: aryx, Mentored)

References

Details

(Whiteboard: [good first bug][lang=xul] see comment 7 for instructions)

Attachments

(2 files, 1 obsolete file)

Attached image q.png
User Agent: Mozilla/5.0 (X11; Linux i686; rv:35.0) Gecko/20100101 Firefox/35.0 Iceweasel/35.0a2
Build ID: 20141111004002

Steps to reproduce:

In about:preferences#privacy
the user is very worried that "Remove all cookies" will do just that.


Actual results:

I don't know, I was too scared to test!!


Expected results:

The button should be relabeled "Remove all cookies shown". (Unless that is not what in fact it actually does!)
Component: Untriaged → Preferences
Flags: needinfo?(philipp)
Summary: remove all cookies button should probably be called remove all cookies shown → Clarify label of "Remove All Cookies" button to indicate whether it removes all cookies or just removes the cookies shown
So, that button actually does just remove the cookies that are shown.

Therefore, re-labeling the button makes sense. That said, »Remove all cookies shown« sounds a little clunky to me, but I couldn't come up with something better either.

Sevaan, do you happen to have a better idea for a label?
Flags: needinfo?(philipp) → needinfo?(sfranks)
"Remove All"? I think that might make it clearer that this is about the cookies listed above rather than all cookies in general. It might also make sense to re-label "Remove Cookie(s)" as "Remove Selected".
OS: Linux → All
Hardware: x86 → All
Version: 35 Branch → Trunk
Don't say "Remove All". Say "Remove these" or "Remove selected" if nothing longer fits.
(In reply to Dan Jacobson from comment #3)
> Don't say "Remove All". Say "Remove these" or "Remove selected" if nothing
> longer fits.

I was talking about two distinct buttons and you seem to be confusing them.
You are right. I am writing this out of memory. Sorry. You guys take care of it! Thanks.
(In reply to Dão Gottwald [:dao] from comment #2)
> "Remove All"? I think that might make it clearer that this is about the
> cookies listed above rather than all cookies in general. It might also make
> sense to re-label "Remove Cookie(s)" as "Remove Selected".

+1 to this suggestion.
Flags: needinfo?(sfranks)
These buttons are here:
http://mxr.mozilla.org/mozilla-central/source/browser/components/preferences/cookies.xul#94

We'll need to change the entity names (e.g. removeSelectedCookie.label, removeSelectedCookie.accesskey, removeSelectedCookies.label, removeAll.label, removeAll.accesskey) and update the strings here:
http://mxr.mozilla.org/mozilla-central/source/browser/locales/en-US/chrome/browser/preferences/cookies.dtd
Mentor: dao
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [good first bug][lang=xul] see comment 7 for instructions
Assignee: nobody → archaeopteryx
Status: NEW → ASSIGNED
Comment on attachment 8536514 [details] [diff] [review]
patch, v2

I think we settled on "Remove All" and "Remove Selected".

What's the purpose of button.removeSelectedCookies.label? That entity is completely obsoleted by the removeSelectedCookies string, right?
Attachment #8536514 - Flags: review?(dao) → review-
Archaeopteryx, are you still working on this?
Flags: needinfo?(archaeopteryx)
Attached patch patch, v3Splinter Review
Attachment #8536514 - Attachment is obsolete: true
Flags: needinfo?(archaeopteryx)
Attachment #8541855 - Flags: review?(dao)
Comment on attachment 8541855 [details] [diff] [review]
patch, v3

Looks good, thanks!
Attachment #8541855 - Flags: review?(dao) → review+
https://hg.mozilla.org/mozilla-central/rev/efe3dcc7a745
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 37
So I got notified that the plural form can't be used like this because some locale require a number in the string. Should I add the number to the English string ("Remove 5 Selected"), or keep the English one like it is and add a localization note that the localizers can add "#1" if they need the number of cookies selected? More background on this: https://groups.google.com/forum/#!msg/mozilla.dev.l10n/sN8OfMIVk5A/vw82p1-BvuAJ

Furthermore, a localization node for the accesskey in the .dtd file with the label in the properties has been requested.

Should I reopen this bug or file a follow-up dependent bug?
Thoughts, Matej?
Flags: needinfo?(matej)
(In reply to Sevaan Franks [:sevaan] from comment #16)
> Thoughts, Matej?

I was following pretty well until comment 15. Do we have to include the number? It seems to me that "Remove selected" works if you're deleting one or many. The number is superfluous.
Flags: needinfo?(matej)
It works for English and other locales with one or two plural forms, but not for every language.
See for example this old discussion on dev-l10n: https://groups.google.com/forum/#!msg/mozilla.dev.l10n/sN8OfMIVk5A/vw82p1-BvuAJ

We can also leave English as it is, as long as the localization comment clearly explains how to add the number if needed.
New bug, please.
Verified fixed on Windows 7 64bit, Ubuntu 13.10 32bit and Mac OSX 10.8.5 using latest Nightly 37.0a1 (buildID: 20150104030205).
Status: RESOLVED → VERIFIED
Archaeopteryx, can you take care of filing the new bug? Thanks!
Flags: needinfo?(archaeopteryx)
Follow-up bug is bug 1118226.
Flags: needinfo?(archaeopteryx)
You need to log in before you can comment on or make changes to this bug.