Closed Bug 1103396 Opened 5 years ago Closed 5 years ago

Move Thunderbird start page to bedrock and make it localizable

Categories

(www.mozilla.org Graveyard :: Thunderbird, defect)

Production
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: wsmwk, Assigned: kohei)

References

()

Details

(Whiteboard: [kb=1587478] )

Attachments

(4 files, 2 obsolete files)

+++ This bug was initially created as a clone of Bug #836461 +++

This bug for moving Thunderbird start page from PHP to Bedrock, and getting them localized.
 
https://www.mozilla.org/thunderbird/release/start/?uri=/thunderbird/start/

Kohei, can  you guide and drive this?
pascalc suggests "You will also probably need pmac (paul McLanahan) to do code review."
Will work on this next week.
Status: NEW → ASSIGNED
Whiteboard: [kb=1587478]
As part of the migration, I think it would be nice to apply mozilla.org's Sandstone theme to this start page. Wayne: What do you think of the attached design?
Flags: needinfo?(vseerror)
Attached file pull request
(In reply to Kohei Yoshino [:kohei] from comment #2)
> Created attachment 8528032 [details]
> Screenshot showing the redesigned start page
> 
> As part of the migration, I think it would be nice to apply mozilla.org's
> Sandstone theme to this start page. Wayne: What do you think of the attached
> design?

I like it. It will help it stand out much more in the Thunderbird UI.

Can you make progress for now without my wording changes which I owe you?
Flags: needinfo?(vseerror) → needinfo?(kohei.yoshino)
Okay. Once the new copy is ready (for the 10th anniversary, I guess), I can make the change again, anytime. So now I'll request reviews for my pull request with the current copy.
Flags: needinfo?(kohei.yoshino)
So is it okay to start using the new start page only in the en-US locale, while waiting for the new copy and the l10n?
Flags: needinfo?(vseerror)
(In reply to Kohei Yoshino [:kohei] from comment #6)
> So is it okay to start using the new start page only in the en-US locale,
> while waiting for the new copy and the l10n?

That's a good way forward.
Flags: needinfo?(vseerror)
Got it.
Summary: [bedrock] move Thunderbird start page to bedrock and localize → Move Thunderbird start page to bedrock and make it localizable
:kohei, attached is the new text, with updated URLs.

Is there anything else you need from me?
Flags: needinfo?(kohei.yoshino)
That's enough. Thanks!
Flags: needinfo?(kohei.yoshino)
Changed the layout so all texts fit well.
Attachment #8528032 - Attachment is obsolete: true
Comment on attachment 8531620 [details]
Screenshot showing the redesigned start page w/ layout changes

Looks good. You will also want to test it as an actual start page in Thunderbird in the 3 layouts of vertical, classic and wide.
Attachment #8531620 - Flags: feedback+
Oh, and under Happy Birthday you have an additional like of "learn more".  Is that intentional, and to what does it point?
Ah thanks, I forgot to remove that link ;)

The page is responsive, works well with the vertical or wide view as well.
responsive is good.
more nits 
- I simplified "More Tips" as just "Tips"
- I simplified "New Features" as just "Features" (besides, the features are no longer new)
- I simplified "Over 75% of" as "Most" (but if you think 75% reads much better, I'm not stuck on my wording)

some of the links had also changed/corrected. They are correct in my html attachment.
Attached image Screenshot, copy fixed
Thanks again! Fixed the copy...
Attachment #8531620 - Attachment is obsolete: true
What's the status here? Wayne, we need that stuff merged into master to start working on localizing it.
I think we are just waiting for a review on GitHub.
kohei, please change  "Most of Thunderbird" to "Most Thunderbird" and you can run with it.  Thanks.
++
Hmm, my change has somehow been reverted. Will fix it shortly along with the copy...
(In reply to Kohei Yoshino [:kohei] from comment #20)
> Hmm, my change has somehow been reverted. Will fix it shortly along with the
> copy...

How'd it go?  Is there a staged version for review?
Flags: needinfo?(kohei.yoshino)
I have fixed my pull request and set up my stating server:
http://bedrock.britegrid.com/en-US/thunderbird/release/start/
Flags: needinfo?(kohei.yoshino)
(In reply to Kohei Yoshino [:kohei] from comment #22)
> I have fixed my pull request and set up my stating server:
> http://bedrock.britegrid.com/en-US/thunderbird/release/start/

Thanks koehi. Stage looks great except one item to fix - "Contribute" should link to https://wiki.mozilla.org/Thunderbird#Contributing  which is the same link used for "Get Involved".
Thank you. Fixed.
Duplicate of this bug: 1113481
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/7d9be9efcca63ec89c5cff1ff12eb2c15275cdfc
Fix Bug 1103396 - Move Thunderbird start page to bedrock and make it localizable

https://github.com/mozilla/bedrock/commit/4ebc3fdaea83ed68642762260f27552b8f4614aa
Merge pull request #2539 from kyoshino/bug-1103396-thunderbird-start

Fix Bug 1103396 - Move Thunderbird start page to bedrock and make it localizable
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
I am reopening because we need a specific patch added to activate a staging environment for localizers for the new page.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
https://github.com/mozilla/bedrock/pull/2607
After talking with pmac, we can activate the page in bedrock for all locales in dev-allizom.org with a patch to dev.conf. That should allow localizers to see their translation and QA it.
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/cd596581055aed1e5e293339f6fef798aae098b6
Bug 1103396: activate thunderbird start page for all locales on dev-allzom.org

https://github.com/mozilla/bedrock/commit/80488192c3b38f33e3310318f6dbd077f455e383
Merge pull request #2607 from pascalchevrel/thunderbird_start_page

Bug 1103396: activate thunderbird start page for all locales on dev-allizom.org
The new en-US page has just been pushed to production \o/
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Blocks: 1115285
Depends on: 1118368
Product: www.mozilla.org → www.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.