Fullscreen video background stutter

RESOLVED INVALID

Status

()

RESOLVED INVALID
4 years ago
3 years ago

People

(Reporter: infrardeca, Unassigned)

Tracking

33 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/38.0.2125.111 Safari/537.36

Steps to reproduce:

1. Load this page - D-Light theme (template) for WP: http://www.shindiristudio.com/darkone/home-video/
2. Wait for the background video to play - observe fps
3. Scroll down and check the site's animation performance of counters, pricing tables etc.


Actual results:

The youtube background video stutters
3x the CPU usage compared to Chrome
Everything (scrolling, CSS3 animations, counters) are sluggish.

Above issues happen even on latest PC's with good specs.


Expected results:

Silky smooth video background
Acceptable performance when scrolling and displaying animated components (charts, counters etc.)

Or...is it just a poorly written theme with too much bloat and I should switch to something else?
Hi Infrardeca,

I have tested your issue on latest Firefox release (43.0.3) and latest Nightly (46.0a1) and I could not  reproduce it. I accessed the link that you posted and worked properly. I didn't quite understand what you were saying about the theme. It's a Firefox theme or a website theme ? Where can I get it or set it ?

Firefox: 46.0a1, Build ID: 20151223140742, User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Firefox: 46.0a1, Build ID: 20160103030302, User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0

Can you please test this on the latest Firefox release (43.0.3) or latest Nightly (46.0a1, https://nightly.mozilla.org/) and tell me if this still reproduces for you ? When doing this please use a new fresh Firefox profile, maybe also in safe mode (https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems). Sometimes this kind of issues could appear when using custom settings, themes or some addons. 


Thanks,
Cosmin
Flags: needinfo?(infrardeca)
(Reporter)

Comment 2

3 years ago
Hello Cosmin,

wow, this is old :)

I was talking about a website theme (=template) for WordPress and the link posted was guiding to that theme (actually a live demo of it for "try before you buy" purposes).

Anyways, I've tested it in 43.0.3 and it works perfectly now, no issues.

Marked as resolved, thanks for reminding!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(infrardeca)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.