little UI-bug on large ftp-directories

RESOLVED INCOMPLETE

Status

()

--
trivial
RESOLVED INCOMPLETE
17 years ago
7 years ago

People

(Reporter: BesTo, Unassigned)

Tracking

Trunk
Future
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.5+) Gecko/20011114
BuildID:    2001-11-14-10

(Sorry for my bad english. :) )
(Please see the file I've uploaded !)
This bug only appears if the directory is so large that scrollbars on the right
and you go direct via URL in the dir or you make a refresh.
(I mean that it not appear when the dir is a sub-dir.)

Reproducible: Always
Steps to Reproduce:
1. Go direct to ftp://ftp.mozilla.org/pub/mozilla/nightly
2. Scroll to the bottom (1)
3. Then press the down-button (2)
   (The bug appears too if you press the up-button.)

Actual Results:
The complete screen now "jumping" some pixels ahead.
The load-arbor (3) appears and the size of the files and the date going
some characters to the right (4).
(Reporter)

Comment 1

17 years ago
Created attachment 57984 [details]
example

Comment 2

17 years ago
Based on the steps provided, I can't reproduce with the Nov 15th build
(2001-11-15-06).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

17 years ago
Tested with:
mozilla-win32-installer-sea-2001-11-15-09-trunk.exe
The bug is still there.
Scroll with (1) to the bottom and then press (2) and the bug appears.
(You can then make a "Refresh" and then press (2) and you will see the bug again.)
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 4

17 years ago
I'm confused by the references of (1) and (2). What do you mean ? Also, how are
you scrolling the window ? Using arrow keyboard keys, clicking on arrow
scrollbar on window, or dragging the window scrollbar ?
(Reporter)

Comment 5

17 years ago
Sorry, I didn't now the right english words and so I made a Pic as attachment.

I think I mean that when I will be sure that the bug appear, I dragging the
window down by the scrollbar. Then make a refresh. And after the refresh I
clicking on arrow scrollbar on window (down). And then the bug appear.

(Oh, I see I had chose the wrong component. Next time I will make it better. :) )

Comment 6

17 years ago
Is this still happening on the latest build ? If so, does resizing the window
fix it ? Based on the steps provided, I can get the folder icons to drop out and
then appear when scrolling the window. However, I 'm not able to reproduce the
painting issue described.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

17 years ago
I have it tested with build: mozilla-win32-installer-sea-2001-12-09-11-trunk.exe
(4) is gone.
But (3) is still there.
When I'm clicking on arrow scrollbar on window (down) the dirctory will not be
loaded again. Isn't it?
But the load-arbor appears.
And when the loading of the dir is finished normally the load-arbor should gone
but it didn't.
It's really not a big bug but it have confuses me. :)

> If so, does resizing the window fix it ?
No.

> ... I can get the folder icons to drop out and then appear when scrolling the
> window.
Sorry, my english is to bad to understand this sentence. :)
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 8

17 years ago
The load indicator in the bottom right hand corner turns a dark grey when you 
select the down arrow or up arrow on the window. To see this happen, go to the 
URL the reporter mentions, using the slider scroll all of the way to the bottom. 
The load indicator section should not have changed color, it should at this 
point still be the same color as the rest of the window. Now, select the down or 
up arrow on the scroll bar, the load indicator should now be a dark grey, or 
whatever it changes to based on the theme you have loaded. This should be a UI 
bug and not a layout bug. Assigning to the GUI component, if that is wrong, I 
apologize.
Assignee: attinasi → blakeross
Status: UNCONFIRMED → NEW
Component: Layout → XP Apps: GUI Features
Ever confirmed: true
QA Contact: petersen → sairuh
over to Mr Baetz
Assignee: blakeross → bbaetz
This is either a lyout or imglib bug. I'll attach an html file with the same effect.

based on how all the images load one by one, -> imglib. This may be a dupe of
hte "reloading multiple images all the time" bug which stuart has.
Assignee: bbaetz → pavlov
Component: XP Apps: GUI Features → ImageLib
QA Contact: sairuh → tpreston
Created attachment 61401 [details]
html produced by this directoty

Updated

17 years ago
Target Milestone: --- → Future

Updated

12 years ago
Assignee: pavlov → nobody
QA Contact: tpreston → imagelib
I don't think I see this happening, but I'm not sure I understand the instructions either. Can anyone that experienced this bug try a nightly build and see if this still occurs?
No activity, marking this as incomplete.
Status: NEW → RESOLVED
Last Resolved: 17 years ago7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.