H.264 videos not playing in firefox 33.1 in android 4.4.2 on mediatek MT6592T

RESOLVED DUPLICATE of bug 1100126

Status

()

Firefox for Android
Audio/Video
RESOLVED DUPLICATE of bug 1100126
3 years ago
2 years ago

People

(Reporter: Leo_sk, Unassigned)

Tracking

({reproducible})

34 Branch
ARM
Android
reproducible
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Android; Mobile; rv:33.0) Gecko/33.0 Firefox/33.0
Build ID: 20141106113154

Steps to reproduce:

Go to any site with h.264 video like 'http://www.html5videoplayer.net/html5video/mp4-h-264-video-test/' and play the video.


Actual results:

The video keeps on loading without playing. This continues even when entire video has been completely loaded. If at any point video is stopped and resumed, a collection of coloured boxes appear with no audio i.e. video is completely broken


Expected results:

Video should have played normally as in chrome on the same machine. The problem occurs only on mediatek chipset and not on snapdragon and exynos.
(Reporter)

Updated

3 years ago
Keywords: reproducible
Hardware: Other → ARM
This should be solved with Firefox Beta, can you try out Firefox Beta on Google Play?
Flags: needinfo?(sk.griffinix)
(Reporter)

Comment 2

3 years ago
I ll try in firefox beta
Flags: needinfo?(sk.griffinix)
(Reporter)

Comment 3

3 years ago
Not working in firefox 34 beta also.
Version: Firefox 33 → Firefox 34
(In reply to Leo_sk from comment #3)
> Not working in firefox 34 beta also.

Ok, last effort can you try out Nightly (http://nightly.mozilla.org) for Android and report back if that is working for you?

On Nightly we enabled a new video decoding backend for Android 4.1+.
Flags: needinfo?(sk.griffinix)
(Reporter)

Comment 5

3 years ago
Ok
Flags: needinfo?(sk.griffinix)
(Reporter)

Comment 6

3 years ago
In nightly the video plays with normal sound but the screen keeps on flashing.
Thanks. Video fixed via bug 1014614. Flickering issues are bug 1100126.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1100126
You need to log in before you can comment on or make changes to this bug.