Not all characters in lowercase greek alphabet render correctly, regardless of font settings

RESOLVED WONTFIX

Status

()

Core
Layout: Text
RESOLVED WONTFIX
16 years ago
15 years ago

People

(Reporter: Michael A. Sypes, Assigned: Hixie (not reading bugmail))

Tracking

({fonts, pp, qawanted})

Trunk
PowerPC
Mac System 8.6
fonts, pp, qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: blocked: need info -- is this a fonts problem or a mozilla problem?, URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.5) Gecko/20011011
BuildID:    2001101117

Using either strict numeric or alphanumeric codes, most of the letters of the
Greek alphabet do not render correctly. Either a large question mark or the
astrological symbol for Leo in a rounded square shows up.
This occurs using Latin-1, UTF-8, and ISO-8859 character encodings.
Attempts to print pages containing these characters also cause Mozilla to crash.

Reproducible: Always
Steps to Reproduce:
1. Go to the specified URL for an example.
2. Compare the screen shot JPG with whatever you see.
3. Try to print if you like.

A list of fonts installed is included in the URL above.
To repeat it's <http://www.bmb.psu.edu/courses/psu16/sypes/fonttest.html>
Reporter: Your build is really old. Please try a more recent build:
http://ftp.mozilla.org/pub/mozilla/nightly/latest/MacMozillaInstall.sea.bin
(Reporter)

Comment 2

16 years ago
I had not updated for a while due to another bug (key strokes resulting in
double  inputs = Bug # 106022).
Now that that bug is resolved, I've just installed Build ID #2001111514. Nothing
has changed; the rendering is the same as with the previous build.
Keywords: fonts

Comment 3

16 years ago
ccing pinkerton
No dupes found. Marking NEW.

Is Layout the right place for this?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

16 years ago
I am now using build ID 2001121104.
The improper rendering is still present. No change
I have also added to the example URL
<http://www.bmb.psu.edu/courses/psu16/sypes/fonttest.html> pages using CSS.

-Michael 
(Reporter)

Comment 6

16 years ago
Now using build ID 2002011003.
No improvement/change.
(Assignee)

Comment 7

16 years ago
On Mandrake 8.1, I get three lines of "abc" and two lines of a greek alpha
character, as is expected, for all three test cases.

What we need is someone else on Mac to see what they get. Pinkerton?
Keywords: pp, qawanted
Whiteboard: blocked: need info -- is this a fonts problem or a mozilla problem?
(Assignee)

Comment 8

16 years ago
bryner looked at the test pages with a month old build on Mac OS X, and got
exactly the same results as me.
(Reporter)

Comment 9

16 years ago
Now using build ID 2002012103.
No improvement/change.
(Reporter)

Comment 10

16 years ago
Now using Build ID 2002020405
No improvement/change
See <http://www.bmb.psu.edu/courses/psu16/sypes/fonttest.html>

Note: I'm using Mac OS 8.6, not OS X

(Standards are great, IF they work.)
(Reporter)

Comment 11

16 years ago
Just installed Build ID 2002022603.
Still doesn't work properly.
(Reporter)

Comment 12

16 years ago
Just downloaded build ID 2002040208.
Still no change. Characters do not render when coded according to "standards".
(Assignee)

Comment 13

16 years ago
Telling us that there is no change doesn't really help (but thanks anyway). The
problem is that none of our developers seem to be able to reproduce this
problem, so we have nothing to work on. All I can really recommend is to get the
source code and try debugging it yourself; I'm sure we'd be happy to help.

Comment 14

16 years ago
Accessing [http://www.hclrss.demon.co.uk/unicode/greek.html], it appears
Mac/2002080208/9.2.2 handles the small-letter greek symbols just fine, except
for some archaic and extended characters, which probably aren't included in the
Mac Greek fonts.

Do you agree, Michael?
(Reporter)

Comment 15

16 years ago
I haven't found anything to download newer than Build ID 2002072203.
Attempting to access that page just causes my machine to hang. That has happened
with every version of Mozilla I have ever used.

Comment 16

15 years ago
For the test case URL, the last two symbols on the test pages are specified in
the HTML with HTML entities.  The character set specified for the document is
meaningless for these, since you're expressing a logical character through the
HTML entity, not in the form of raw text on the page.

Given that you're using both a symbolic entity and a numeric Unicode entity and
are getting the same character.

One possibility is that Mozilla is pulling the character for this Unicode code
point.  I was unable to find, however, a Unicode glyph that looks like the
character in the screen shot.  It's conceivable that this glyph could be created
using a 'leo' character (or an 'ohm' symbol or greek omega?) with a combining
circle, but this isn't likely to occur accidentally (it would require two
characters).

The only other likely cause, in my view, is that Mozilla is finding the correct
code point, but it's locating an 8-bit "symbol" font or some other font that
doesn't have a proper character -> glyph mapping table.

Going through that font list might help identify if this is indeed the problem.
 The reporter might try removing all but the bare essentials from the installed
fonts (including all of the symbol fonts) and see if the problem clears up.  If
he has a lot of spare time, he might also try locating this specific glyph in
one of his fonts and see what character it corresponds to.

Comment 17

15 years ago
Some aspects of that last comment are unintelligible (sorry; I'm in a meeting
and not paying enough attention to what I'm typing).

"Given that you're using both a symbolic entity and a numeric Unicode entity and
are getting the same character:

One possibility is that Mozilla is pulling the WRONG character for this Unicode
code point."
Resolving as WONTFIX, since we dropped Mac OS Classic support some time ago.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Component: Layout → Layout: Fonts and Text
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.