[mach] kbrd shortcuts broken until menu opened once

RESOLVED WORKSFORME

Status

()

Core
Keyboard: Navigation
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: cyrus, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Trunk
Future
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
cmd-c and cmd-v don't work under fizz-mach
Reporter: Please always add your build ID

-> Keyboard navigation
Assignee: asa → aaronl
Component: Browser-General → Keyboard Navigation
QA Contact: doronr → sairuh
(Reporter)

Comment 2

16 years ago
No build ID (no official builds of fizz-mach yet). built from Nov 14 (PM) tree.
is this limited to fizz-mach? if yes, then qa contact should go to zach [till
verif bits become available for me to test]...

however, lemme know if this is also seen on the usual os x bits available...
Assignee: aaronl → pinkerton
QA Contact: sairuh → zach
(Assignee)

Comment 4

16 years ago
do any other cmd keys work? did you try control-v and control-c? 
(Reporter)

Comment 5

16 years ago
no ctrl-v and ctrl-c do not work. Under certain circumstances (not sure 
which) I can get cmd-v to work in the URLBar, but in general it (and cmd-c) 
seem broken.
*** Bug 111796 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

16 years ago
the problem is that key shortcuts don't work until after the menu has been
opened once. Once you do that, they work just fine and dandy. I'm not sure why
this is the case, given that we generally don't use the shortcut mechanism
provided by the OS....and then, why would this be different from carbon? 

these binding should be handled by XBL, right saari? could something not be
installed correctly? Does that ring a bell dbaron?
Status: NEW → ASSIGNED
Summary: [fizz-mach] cut and paste kbrd shortcuts broken → [fizz-mach] kbrd shortcuts broken until menu opened once
(Assignee)

Comment 8

16 years ago
here's the problem:

when dispatching the key event, the view manager thinks that the x/y position is
in one of the views (nsView::PointIsInside() returns true because the view
clipRect has a width/height). On CFM, this cliprect has a 0,0 width/height so
the event goes on down into the presShell.

Any ideas as to why we'd have a sized clipRect on mach-o but not cfm? it's gotta
be more ifdef-fu. Thoughts as to where? I didn't find any in the view manager.
(Assignee)

Comment 9

16 years ago
*** Bug 118285 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Summary: [fizz-mach] kbrd shortcuts broken until menu opened once → [mach] kbrd shortcuts broken until menu opened once

Comment 10

16 years ago
Additional info: For me (Build 2002040403) I have to actually choose the menu
entry before that particular kbd-shortcut will work. So, if I want to use cmd-c,
the first time, I want to copy something, I have to go to the Edit menu and pick
it there. 

After that cmd-c works, but none of the other shortcuts work. They each have to
be 'activated', but choosing them in the menu once, and then the shortcut works.
Pasting is the same thing.

Is this planned for 1.0? Doesn't look like it, but it's a major hassle, and
seems like a completeness issue to me.
(Assignee)

Updated

16 years ago
Target Milestone: --- → Future

Comment 11

16 years ago
This now works... with my 20020721 build... and has worked for a few weeks... I
am not applying any patches. Just a straight pull and build. This bug should be
closed.

Comment 12

16 years ago
resolve as worksforme per comment 11
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.