[FFOS2.0][Woodduck][SEC]PUK2 Block screen can not come out after PUK2 Blocked.

RESOLVED INVALID

Status

Firefox OS
Gaia::Settings
P2
normal
RESOLVED INVALID
4 years ago
3 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [POVB])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
DEFECT DESCRIPTION:[SEC]PUK2 Block screen can not come out after PUK2 Blocked.
 
  REPRODUCING PROCEDURES:
 1. Load a simcard to the phone which with PIN2's AttemptsRemaining = 3, 
    PUK2's AttemptsRemaining = 10;
 2. Go to "settings->...>FDN", input incorrect PIN2 Code to block PIN2;
 3. After the PIN2 block, PUNK2 input screen come out;
 4. Input 10 times incorrect PUK2 Code, PUK2 Block screen do not come out--ko1;
 5. PIN2 related function do not disabled.--ko2
 
 
  EXPECTED BEHAVIOUR:
 4. Input 10 times incorrect PUK2 Code, PUK2 Block screen should come out;
 5. PIN2 related function should be disabled.
 
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

4 years ago
Created attachment 8527436 [details]
mtklog-SWv7G20-p-p27.rar

Comment 2

4 years ago
Hi Shawn,
Could you help to check?
Blocks: 1054172
Flags: needinfo?(sku)

Comment 3

4 years ago
Hi Woodduck:
 Please help check with your modem to see what will be reported to Gecko/Gaia!!

Thanks!!
Shawn
Flags: needinfo?(wudduc)

Comment 4

4 years ago
Created attachment 8530223 [details]
PUK_Block.log

// RIL_E_PASSWORD_INCORRECT
11-28 17:15:45.287   161   626 I Gecko   : RIL Worker: [0] Solicited response for request type 5, token 142, error 3

// RIL_E_PASSWORD_INCORRECT
11-28 17:15:54.922   161   626 I Gecko   : RIL Worker: [0] Solicited response for request type 5, token 143, error 3

// RIL_E_PASSWORD_INCORRECT
11-28 17:16:10.007   161   626 I Gecko   : RIL Worker: [0] Solicited response for request type 5, token 144, error 3

// RIL_E_PASSWORD_INCORRECT
11-28 17:16:19.202   161   626 I Gecko   : RIL Worker: [0] Solicited response for request type 5, token 145, error 3

// RIL_E_PASSWORD_INCORRECT
11-28 17:16:36.803   161   626 I Gecko   : RIL Worker: [0] Solicited response for request type 5, token 146, error 3

// RIL_E_PASSWORD_INCORRECT
11-28 17:16:47.047   161   626 I Gecko   : RIL Worker: [0] Solicited response for request type 5, token 147, error 3

// RIL_E_PASSWORD_INCORRECT
11-28 17:16:59.135   161   626 I Gecko   : RIL Worker: [0] Solicited response for request type 5, token 148, error 3

// RIL_E_PASSWORD_INCORRECT
11-28 17:17:11.814   161   626 I Gecko   : RIL Worker: [0] Solicited response for request type 5, token 149, error 3

// RIL_E_PASSWORD_INCORRECT
11-28 17:17:20.505   161   626 I Gecko   : RIL Worker: [0] Solicited response for request type 5, token 150, error 3

// RIL_E_GENERIC_FAILURE
11-28 17:17:30.244   161   626 I Gecko   : RIL Worker: [0] Solicited response for request type 5, token 151, error 2

Comment 5

4 years ago
Hi Reporter,
 It looks like the only way to fix this issue is to check retry count for PUK2.

Pure FxOS does not read retry counter when enter Call Setting.
Might need partner to check if you can implement this by yourself since retry count check is done by your side.
Flags: needinfo?(sku) → needinfo?(sync-1)

Updated

4 years ago
Flags: needinfo?(wudduc)
HI reporter, is there any update on this bugper comment 5?

Updated

3 years ago
Blocks: 1107999
Whiteboard: [POVB]
(Reporter)

Comment 7

3 years ago
hi mozilla:
    there are no progress
(Reporter)

Comment 8

3 years ago
hi mozilla:
    Can you tell me the code which to get retry count?
shawn, could you please help with comment 8?
Flags: needinfo?(sku)

Comment 10

3 years ago
Hi there:

you can check ftu/js/sim_manager.js for the usage.
Example:
var request = icc.mozIcc.getCardLockRetryCount("puk2");
    request.onsuccess = function() {
      var retryCount = request.result.retryCount;
      if (retryCount) {
        // update retry counter on UI
      } else {
        // no more retry
      }
    };
    request.onerror = function() {
      console.error('Could not fetch CardLockRetryCount', request.error.name);
    };

Please let me know if any problem you may have.
Flags: needinfo?(sku)
(Reporter)

Comment 11

3 years ago
hi mozilla:
    谢谢你的例子,但是在settings中PUK2的显示是在settings/js/simcard_dialog.js文件中。
    目前的问题是当PUK2码错误次数达到10次时,依旧停留在PUK2的界面并且PUk2相关的功能还能使用,但是当PUK2码错误10次后本sim卡应该报废。故当错误次数达到10次时结束PUK2的界面,PUK2的相关功能也应该停止使用。

Updated

3 years ago
Flags: needinfo?(sku)

Comment 12

3 years ago
(In reply to sync-1 from comment #11)
> hi mozilla:
>     谢谢你的例子,但是在settings中PUK2的显示是在settings/js/simcard_dialog.js文件中。
>    
> 目前的问题是当PUK2码错误次数达到10次时,依旧停留在PUK2的界面并且PUk2相关的功能还能使用,但是当PUK2码错误10次后本sim卡应该报废。
> 故当错误次数达到10次时结束PUK2的界面,PUK2的相关功能也应该停止使用。

You can close the FDN setting, and also disable FDN related feature when retry counter <= 0.

Besides, this is Gaia scope, might need Gaia's help if partner still got issue.
Flags: needinfo?(sku)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(sync-1)
Resolution: --- → INVALID

Updated

3 years ago
Flags: needinfo?(chen.ding)

Comment 13

3 years ago
Mail from Chen Ding:
=======================================
dear all:
      https://bugzilla.mozilla.org/show_bug.cgi?id=1103811#c12
这个问题已经修复,提交VAL验证

Best Regards!

丁琛  Alvin   Application Engineer
Flags: needinfo?(chen.ding)
You need to log in before you can comment on or make changes to this bug.