Enable parallel build by default

RESOLVED FIXED

Status

Firefox OS
Gaia::Build
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: rickychien, Assigned: rickychien)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

46 bytes, text/x-github-pull-request
gduan
: review+
Details | Review | Splinter Review
(Assignee)

Description

3 years ago
I think parallel build is stable now, it's time to enable it by default.
(Assignee)

Comment 1

3 years ago
Created attachment 8527439 [details] [review]
Gaia PR
Attachment #8527439 - Flags: review?(gduan)
try result?
(Assignee)

Comment 3

3 years ago
Push to try:

https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=807dba11c777

waiting for green.
Comment on attachment 8527439 [details] [review]
Gaia PR

Try result seems good. let's merge it and see if there's anything we haven't considered yet.
Attachment #8527439 - Flags: review?(gduan) → review+
(Assignee)

Comment 5

3 years ago
Merged.

https://github.com/mozilla-b2g/gaia/commit/408130c5845ba3c4ec255bb1e29de270a81165d5
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
reverted in case this also causing https://treeherder.mozilla.org/ui/logviewer.html#?job_id=890173&repo=b2g-inbound
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 7

3 years ago
Created attachment 8529556 [details] [review]
Gaia PR v2

PR has been updated. Fix windows path issue.
Attachment #8527439 - Attachment is obsolete: true
Attachment #8529556 - Flags: review?(gduan)
Comment on attachment 8529556 [details] [review]
Gaia PR v2

r=gduan, I think we can merge it if window/linux/mac can pass.
So, the reason of last backout is due to 2 reasons,
1. We throw error while l10n resource is not found instead of console.warn from a recent commit.
2. Communication and callscreen might have race condition while building in parallel.
That's why we put some workaround in this patch. They should be removed til bug 1093267 is fixed.

I just found out that we cannot execute 'make APP=callscreen' due to reason 1. We should also highlight it.
Attachment #8529556 - Flags: review?(gduan) → review+
(Assignee)

Comment 9

3 years ago
Thanks George's help for finding out root cause.

Merged.

https://github.com/mozilla-b2g/gaia/commit/b29f75d68e037fa74620d55fdbd945880065d274
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

3 years ago
Added workaround for callscreen will increase some building time. I'm looking forward to waiting bug 1093267 to be fixed.
You need to log in before you can comment on or make changes to this bug.