Fix intermittent failure in test_sms_with_picture_attached.py

RESOLVED FIXED

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: viorela, Assigned: viorela)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Assignee

Description

5 years ago
Posted file logcat of the issue
Test test_sms_with_picture_attached.py is failing intermittently on b2g-i. 
I was able to reproduce the failure locally, by running the automated test. It is not reproducible manually. 
Repro rate: 1 out of 12.  

This failure looks similar to the one described in Bug 1065933.
Jenkins report: http://jenkins1.qa.scl3.mozilla.com/job/flame-kk-319.b2g-inbound.ui.functional.smoke/1335/HTML_Report/

Traceback (most recent call last):
  File "/home/viorelaioia/.virtualenvs/gaia_tests/local/lib/python2.7/site-packages/marionette_client-0.8.4-py2.7.egg/marionette/marionette_test.py", line 264, in run
    testMethod()
  File "/home/viorelaioia/gaia/tests/python/gaia-ui-tests/gaiatest/tests/functional/messages/test_sms_with_picture_attached.py", line 54, in test_sms_cropped_picture
    crop_view.tap_crop_done()
  File "/home/viorelaioia/gaia/tests/python/gaia-ui-tests/gaiatest/apps/gallery/regions/crop_view.py", line 21, in tap_crop_done
    self.marionette.find_element(*self._crop_done_button_locator).tap()
  File "/home/viorelaioia/.virtualenvs/gaia_tests/local/lib/python2.7/site-packages/marionette_client-0.8.4-py2.7.egg/marionette/marionette.py", line 90, in tap
    return self.marionette._send_message('singleTap', 'ok', id=self.id, x=x, y=y)
  File "/home/viorelaioia/.virtualenvs/gaia_tests/local/lib/python2.7/site-packages/marionette_client-0.8.4-py2.7.egg/marionette/decorators.py", line 35, in _
    return func(*args, **kwargs)
  File "/home/viorelaioia/.virtualenvs/gaia_tests/local/lib/python2.7/site-packages/marionette_client-0.8.4-py2.7.egg/marionette/marionette.py", line 621, in _send_message
    "Connection timed out", status=errors.ErrorCodes.TIMEOUT)

TEST-INFO took 468048ms
test_end for test_sms_with_picture_attached.py TestSmsWithPictureAttached.test_sms_cropped_picture logged while not in progress. Logged with data: {"status": "ERROR", "extra": {}, "expected": "PASS", "test": "test_sms_with_picture_attached.py TestSmsWithPictureAttached.test_sms_cropped_picture", "message": "MarionetteException: MarionetteException: Please start a session\n\n", "stack": "Traceback (most recent call last):\n  File \"/home/viorelaioia/.virtualenvs/gaia_tests/local/lib/python2.7/site-packages/marionette_client-0.8.4-py2.7.egg/marionette/marionette_test.py\", line 292, in run\n    self.tearDown()\n  File \"/home/viorelaioia/gaia/tests/python/gaia-ui-tests/gaiatest/gaia_test.py\", line 945, in tearDown\n    MarionetteTestCase.tearDown(self)\n  File \"/home/viorelaioia/.virtualenvs/gaia_tests/local/lib/python2.7/site-packages/marionette_client-0.8.4-py2.7.egg/marionette/marionette_test.py\", line 447, in tearDown\n    self.marionette.set_context(\"content\")\n  File \"/home/viorelaioia/.virtualenvs/gaia_tests/local/lib/python2.7/site-packages/marionette_client-0.8.4-py2.7.egg/marionette/marionette.py\", line 950, in set_context\n    return self._send_message('setContext', 'ok', value=context)\n  File \"/home/viorelaioia/.virtualenvs/gaia_tests/local/lib/python2.7/site-packages/marionette_client-0.8.4-py2.7.egg/marionette/decorators.py\", line 35, in _\n    return func(*args, **kwargs)\n  File \"/home/viorelaioia/.virtualenvs/gaia_tests/local/lib/python2.7/site-packages/marionette_client-0.8.4-py2.7.egg/marionette/marionette.py\", line 606, in _send_message\n    raise errors.MarionetteException(\"Please start a session\")\n"}

Device firmware (date) 	17 Nov 2014 08:12:27
Device firmware (incremental) 	eng.cltbld.20141117.111218
Device firmware (release) 	4.4.2
Device identifier 	flame
Gaia date 	24 Nov 2014 01:35:10
Gaia revision 	2196e28c907b
Gecko build 	20141124015807
Gecko revision 	a0f60519fa38
Gecko version 	36.0a1
Assignee

Updated

5 years ago
Assignee: nobody → viorela.ioia
Assignee

Comment 1

5 years ago
Attachment #8527757 - Flags: review?(robert.chira)
Attachment #8527757 - Flags: review?(florin.strugariu)
Assignee

Updated

5 years ago
QA Whiteboard: [fxosqa-auto-s5]
Comment on attachment 8527757 [details] [review]
Github PR: https://github.com/mozilla-b2g/gaia/pull/26409

r+, although the test is failing at a later step because of Bug 1104624
Attachment #8527757 - Flags: review?(robert.chira) → review+
Attachment #8527757 - Flags: review?(florin.strugariu) → review+
You need to log in before you can comment on or make changes to this bug.