Closed Bug 1104101 Opened 5 years ago Closed 5 years ago

Intermittent test_eme_canvas_blocked.html,test_eme_playback.html | application crashed [@ mozilla::TimeStamp::operator-(mozilla::TimeStamp const &)]

Categories

(Core :: Audio/Video, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla36
Tracking Status
firefox34 --- unaffected
firefox35 --- unaffected
firefox36 --- fixed
firefox-esr31 --- unaffected

People

(Reporter: cbook, Assigned: cpearce)

References

()

Details

(Keywords: crash, intermittent-failure)

Attachments

(1 file)

Windows 7 32-bit mozilla-inbound debug test mochitest-2

https://treeherder.mozilla.org/ui/logviewer.html#?job_id=4156927&repo=mozilla-inbound

07:36:41 WARNING - PROCESS-CRASH | /tests/dom/media/test/test_eme_canvas_blocked.html | application crashed [@ mozilla::TimeStamp::operator-(mozilla::TimeStamp const &)]
07:36:41 INFO - Crash dump filename: c:\users\cltbld\appdata\local\temp\tmpzl0g0j.mozrunner\minidumps\bf4cc69f-50d7-46b0-859f-8ec66123980f.dmp
07:36:41 INFO - Operating system: Windows NT
07:36:41 INFO - 6.1.7601 Service Pack 1
07:36:41 INFO - CPU: x86
07:36:41 INFO - GenuineIntel family 6 model 30 stepping 5
07:36:41 INFO - 8 CPUs
07:36:41 INFO - Crash reason: EXCEPTION_BREAKPOINT
07:36:41 INFO - Crash address: 0x643e4701
07:36:41 INFO - Thread 66 (crashed)
07:36:41 INFO - 0 xul.dll!mozilla::TimeStamp::operator-(mozilla::TimeStamp const &) [TimeStamp.h:27742c3e3137 : 454 + 0x20]
07:36:41 INFO - eip = 0x643e4701 esp = 0x1235f790 ebp = 0x1235f79c ebx = 0x1235f7b8
07:36:41 INFO - esi = 0x0c688000 edi = 0x0cbbab50 eax = 0x00000000 ecx = 0x63740ad9
07:36:41 INFO - edx = 0x003ad7b9 efl = 0x00000216
07:36:41 INFO - Found by: given as instruction pointer in context
07:36:41 INFO - 1 xul.dll!mozilla::MediaDecoderStateMachine::OnVideoDecoded(mozilla::VideoData *) [MediaDecoderStateMachine.cpp:27742c3e3137 : 944 + 0x1c]
07:36:41 INFO - eip = 0x6560ba55 esp = 0x1235f7a4 ebp = 0x1235f7e8
07:36:41 INFO - Found by: call frame info
07:36:41 INFO - 2 xul.dll!mozilla::MediaDataDecodedListener<mozilla::MediaDecoderStateMachine>::DeliverVideoTask::Run() [MediaDataDecodedListener.h:27742c3e3137 : 125 + 0xd]
07:36:41 INFO - eip = 0x65614ffc esp = 0x1235f7f0 ebp = 0x1235f7f4
07:36:41 INFO - Found by: call frame info
07:36:41 INFO - 3 xul.dll!mozilla::MediaTaskQueue::Runner::Run() [MediaTaskQueue.cpp:27742c3e3137 : 194 + 0x5]
07:36:41 INFO - eip = 0x65616bf9 esp = 0x1235f7fc ebp = 0x1235f810
07:36:41 INFO - Found by: call frame info
07:36:41 INFO - 4 xul.dll!nsThreadPool::Run() [nsThreadPool.cpp:27742c3e3137 : 220 + 0xd]
07:36:41 INFO - eip = 0x64443cb3 esp = 0x1235f818 ebp = 0x1235f848
07:36:41 INFO - Found by: call frame info
07:36:41 INFO - 5 xul.dll!nsThread::ProcessNextEvent(bool,bool *) [nsThread.cpp:27742c3e3137 : 830 + 0xd]
07:36:41 INFO - eip = 0x64441df2 esp = 0x1235f850 ebp = 0x1235f924
07:36:41 INFO - Found by: call frame info
07:36:41 INFO - 6 xul.dll!NS_ProcessNextEvent(nsIThread *,bool) [nsThreadUtils.cpp:27742c3e3137 : 265 + 0xc]
07:36:41 INFO - eip = 0x6446a5c7 esp = 0x1235f92c ebp = 0x1235f938
07:36:41 INFO - Found by: call frame info
Component: General → Video/Audio
Flags: needinfo?(cpearce)
Summary: Intermittent test_eme_canvas_blocked.html | application crashed [@ mozilla::TimeStamp::operator-(mozilla::TimeStamp const &)] → Intermittent test_eme_canvas_blocked.html,test_eme_playback.html | application crashed [@ mozilla::TimeStamp::operator-(mozilla::TimeStamp const &)]
Attached patch PatchSplinter Review
I spotted this locally too.

The problem is that the callback called by RequestVideoData expects mVideoDecodeStartTime to be valid, and in the case where we're decoding the first frame and we call RequestVideoData, we don't set mVideoDecodeStartTime. So we should...
Assignee: nobody → cpearce
Status: NEW → ASSIGNED
Flags: needinfo?(cpearce)
Attachment #8528560 - Flags: review?(kinetik)
Attachment #8528560 - Flags: review?(kinetik) → review+
https://hg.mozilla.org/mozilla-central/rev/8d4b73db9b12
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
You need to log in before you can comment on or make changes to this bug.