cannot load any more PDF files, getting NS_ERROR_XPC_SECURITY_MANAGER_VETO

NEW
Unassigned

Status

()

Firefox
PDF Viewer
3 years ago
3 years ago

People

(Reporter: Ray Kiddy, Unassigned)

Tracking

33 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-f-needinfo])

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
Created attachment 8527865 [details]
firefox_error_log.txt

I am running Firefox 33.0 on Ubuntu 14.04 LTS. I have been seeing a bug and will do something to help characterize it if you all have suggestions.

I am having a hardware problem and it shuts down suddenly once a day or so. When it does I boot up and restore my Firefox pages. I tend to keep a bunch of windows open. For example, right now, I have 15 windows open. On average, I have 2 - 7 tabs in each window. One or two of those tabs are usually PDFs. I receive some e-mails with lists of PDF links and I load them from there and then read them later.

So when I restore, I am loading a lot of PDFs again. I see a problem. It does not happen every time but once out of every two or three restarts.

NS_ERROR_XPC_SECURITY_MANAGER_VETO:    (200) 

This is from unity-global-preperty-initializer.js: 238

I know this is not in the best form, but I will attach the log I can copy out and the source that this exception is pointing to.

I can pull firefox source and build, but I do not run that often. And if you want to tell me how to turn on the particular kind of logging you might want, please do.

I am willing to help with this, but not if there is no interest.
(Reporter)

Comment 1

3 years ago
Created attachment 8527866 [details]
FirefoxErrorLocation.png
Are you able to reproduce with a clean profile?
Flags: needinfo?(ray)
Whiteboard: [pdfjs-f-needinfo]
(Reporter)

Comment 3

3 years ago
Is there a way for me to get the URLs of all of my currently loaded tabs? Such as what the restoresession thing gives me? I could try to reproduce this more often if I could get to this.

Or to put this another way,l= I could force-quit my firefox. Can I then launch with a clean profile and point to the restoresession xml or whatever info so that it offers to load that?
Flags: needinfo?(ray)
(Reporter)

Comment 4

3 years ago
FYI, I created a new blank profile and tried copying various things into it so that it would see the session when I selected the 'Restore Previous Session' menu item. It is not seeing the data.

I did:

     % cp -v 80ojm4y2.default/sessionstore-backups/* scox9l9d.blank_20141125/sessionstore-backups/
     % cp 80ojm4y2.default/prefs* scox9l9d.blank_20141125/

Is there something else to copy in so that the "blank_20141125" profile sees the restore data from the "default" profile?
(Reporter)

Comment 5

3 years ago
Created attachment 8528517 [details]
recovery.js

I got the restore session to work in a new instance. This is the file that I needed. But, when I loaded the PDF files in the second instance, the error did not happen. Of course. Would not want it to be too easy, would we?

I will try other times and report if it happens again, or if I can figure out how to make it reproducible.

FYI, I have no privacy concerns in re the sharing of the information in this recovery.js.
(Reporter)

Comment 6

3 years ago
Created attachment 8528531 [details]
browserConsole.txt

Sorry so chatty. Ok, so I spoke too soon. As I went through the second instance pages and loaded the tabs, when I got to the second page of PDFs, it stopped loading.

The stdout of the second instance I had started said:

(firefox:6436): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.40.2/./gobject/gsignal.c:3408: signal name 'load_complete' is invalid for instance '0x7f39a023cb20' of type 'MaiAtkType13b'

(firefox:6436): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.40.2/./gobject/gsignal.c:3408: signal name 'load_complete' is invalid for instance '0x7f39a023a990' of type 'MaiAtkType13b'


The browser content output is attached.

I will leave this running. Let me know if there is anything I can do.

Just on a whim, I ran gdb and attached to this process.

(gdb) bt
#0  0x00007f3a02eb4c6d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f39fe2aa1f0 in ?? () from /usr/lib/firefox/libxul.so
#2  0x00007f39fba91fe4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f39fba920ec in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f39fe2aa236 in ?? () from /usr/lib/firefox/libxul.so
#5  0x00007f39fe2d7f6f in ?? () from /usr/lib/firefox/libxul.so
#6  0x00007f39fe2d809e in ?? () from /usr/lib/firefox/libxul.so
#7  0x00007f39fd9f2841 in ?? () from /usr/lib/firefox/libxul.so
#8  0x00007f39fd9af873 in ?? () from /usr/lib/firefox/libxul.so
#9  0x00007f39fdb9ed65 in ?? () from /usr/lib/firefox/libxul.so
#10 0x00007f39fdb90659 in ?? () from /usr/lib/firefox/libxul.so
#11 0x00007f39fe2d7a31 in ?? () from /usr/lib/firefox/libxul.so
#12 0x00007f39febfc77c in ?? () from /usr/lib/firefox/libxul.so
#13 0x00007f39febd3399 in ?? () from /usr/lib/firefox/libxul.so
#14 0x00007f39febd35fc in ?? () from /usr/lib/firefox/libxul.so
#15 0x00007f39febd384e in XRE_main () from /usr/lib/firefox/libxul.so
#16 0x00007f3a03de23c1 in _start ()

Helps? Who knows. I am running my regular production build, not one I built, so no symbols.
You need to log in before you can comment on or make changes to this bug.