UPS Campus Ship doesn't support netscape above 4.7

RESOLVED FIXED in Sep

Status

P1
normal
RESOLVED FIXED
17 years ago
4 years ago

People

(Reporter: theStation, Assigned: susiew)

Tracking

({ecommerce, qawanted})

unspecified
ecommerce, qawanted

Details

(Whiteboard: [PROPRIETARY-DOM][aok], URL)

(Reporter)

Description

17 years ago
keywords: 4xp, ecommerce, qawanted

  'I'm having problems using the UPS campus ship.'

  "United Parcel Service does not support netscape 
   compatible browsers above 4.7 and only on select 
   windows vers. Why don't you use ie5?"


test case:
  https://www.upscampusship.com/pacific
    this is UPS' web-based replacement for
    your Shipping Log Book. We're one
    of the first companies signed up;
    but soon this will be their preferred
    'log book' for all account holders.

1)  There should be a navigation bar 
    just below the top banner and
    above the words:
    'UPS CampusShip System Login'.
    This is created by a javascript
    loaded from offpage, so I can't even 
    look for why it doesn't work.
    Under netscape4 however, it
    does appear and work correctly.
  keyword: 4xp

2)  Fonts are spec'd in depreciated style,
    they're using stylesheets but seem
    firmly grounded in 1998 design.
    Try viewing from a non-96dpi machine
    such as a Macintosh and you'll see
    the problem in the tiny type at the
    bottom. Esp if you don't have
    formatta installed.

3)  If you are an authorized user,
    the label is auto-created from a form.
    Label.gif is a tall rectangle, rotated
    and displayed in a horizontal rectangle
    at the bottom of the page. 
    Unfortunately, it is 
    rendered as not-rotated and squished
    to fit inside its box at bottom. 

    If you view label.gif in a 
    new browser window it is rendered
   (correctly?)
      Mozilla build ID:2001 11 15 06
      does render the graphic in a new
      window correctly. 96dpi

      Netscape4.7 is too big on printout
      you must reduce to 75percent
      when printing. pixel size 120dpi?

4)  Type on the Label.gif is 'crunchy'. 
    Since label creation is also being 
    implemented 'off the page' by their
    server we don't know why.
(Reporter)

Updated

17 years ago
Keywords: 4xp, ecommerce, qawanted

Comment 1

17 years ago
also layer stuff:
Error: Layer is not defined
Source File: https://www.upscampusship.com/pacific/Scripts/navcond.js
Line: 8
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P1
Whiteboard: [PROPRIETARY-DOM]

Updated

17 years ago
Whiteboard: [PROPRIETARY-DOM] → [PROPRIETARY-DOM][aok]

Comment 2

17 years ago
contacted
Status: NEW → ASSIGNED
Target Milestone: --- → Apr
lookes fixed to me, bc cound you look..? (they changed the login on 25.3.2002)

Comment 4

17 years ago
the pacific site has moved: https://www.upscampusship.com/

unfortunately, the login screen contains IE only window.event stuff when dealing
with the login procedure.

Can anyone with an account please test this site and provide us with a report of
any javascript errors in the javascript console along with the source code so
that we can analyze it?

Reset milestone.

Comment 5

17 years ago
Added to the mozilla financial shames page,
http://blue-labs.org/financial-shames.php
(Reporter)

Comment 6

17 years ago
Supposedly they began updating their whole website in March.
...after much whining and finally rubbing their noses in it...
 >The javascript code that produces your menus is depreciated.
 >The author stopped using it in mid-2000 and 
 >has removed it from his website. 
 >Why are you still using this non-supported, out-dated code?



Issue #1
The menubars now work correctly in Mozilla 1.0rcx
The Login screen also functions as intended.
Close Issue #1


Issue #2
Maybe they want the copyright notice to appear as super-tiny, impossible to
read, jargon at the bottom of an advertisement. 
Then again, they probably don't care.
Otherwise, their text&forms do scale when you text-zoom from Mozilla's view
menu.  Seems they are learning something.
Close Issue #2



Issue #3 & #4
Phone calls to their support center after March yielded very little.

"We only really support InternetExplorer and only on the Windows platforms. All
UPS customers wanting to use the UPSCampusShip system should move to a WindowsPC
with InternetExplorer pre-loaded."

AKA, "we got focused on a platform specific paradigm and spent far too much on
coding that interface. The auto-pagesetup & printing mechanism works and works
well across all M$win+IE versions. If you've figured out how to get around it on
non-M$ machines and without IE, good for you. But don't hold your breath waiting
for us to make it platform/browser independent. Anyway, since you've figured out
how to print the label, the drivers are picking up your packages, and they are
reaching their destinations, aren't they? So why are you complaining about a
couple of extra clicks and menu selections? You're the one not using the
standard windows platform."

--------------
>Can anyone with an account please test this site 
>and provide us with a report of
>any javascript errors in the javascript console 
>along with the source code 
>so that we can analyze it?


I'm not java-savvy, and not familiar with using Mozilla as a dissection tool.
But I do have a UPS password. And weird obscuficated code doesn't scare me.

Anyone care to hold my hand?
eMail me with steps to follow.
Or post them here for all to see.
(Assignee)

Comment 7

17 years ago
I'll contact UPS. -->susiew
Assignee: bclary → susiew
Status: ASSIGNED → NEW
(Assignee)

Updated

17 years ago
Summary: UPS doesn't support netscape above 4.7 → UPS Campus Ship doesn't support netscape above 4.7
(Assignee)

Comment 8

16 years ago
They're actively testing this for Gecko compatibility. Setting Sept. milestone.
Status: NEW → ASSIGNED
Target Milestone: --- → Sep
(Assignee)

Comment 9

16 years ago
UPS Campus Ship should be unblocked now on Mozilla 1.1 and 1.2. Please check if
it is fixed. Thanks.

Comment 10

16 years ago
per comments, fixed. please reopen and assign to default owner if you disagree
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.