Closed Bug 1104301 Opened 6 years ago Closed 6 years ago

Intermittent test_set_window_size.py TestSetWindowSize.test_that_we_can_maximise_the_window | AssertionError: Window width does not use availWidth

Categories

(Core :: Layout, defect)

All
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla36
Tracking Status
firefox34 --- unaffected
firefox35 --- unaffected
firefox36 --- fixed
firefox-esr31 --- unaffected

People

(Reporter: RyanVM, Assigned: rwood)

Details

(Keywords: intermittent-failure)

11:50:34 INFO - TEST-START | test_set_window_size.py TestSetWindowSize.test_that_we_can_get_and_set_window_size
11:50:34 INFO - TEST-PASS | test_set_window_size.py TestSetWindowSize.test_that_we_can_get_and_set_window_size | took 216ms
11:50:34 INFO - TEST-START | test_set_window_size.py TestSetWindowSize.test_that_we_can_maximise_the_window
11:50:35 ERROR - TEST-UNEXPECTED-FAIL | test_set_window_size.py TestSetWindowSize.test_that_we_can_maximise_the_window | AssertionError: Window width does not use availWidth
11:50:35 INFO - Traceback (most recent call last):
11:50:35 INFO - File "/builds/slave/test/build/tests/marionette/marionette/marionette_test.py", line 267, in run
11:50:35 INFO - testMethod()
11:50:35 INFO - File "/builds/slave/test/build/tests/marionette/tests/testing/marionette/client/marionette/tests/unit/test_set_window_size.py", line 74, in test_that_we_can_maximise_the_window
11:50:35 INFO - self.assertEqual(size['width'], self.max_width, "Window width does not use availWidth")
11:50:35 INFO - TEST-INFO took 538ms
11:50:35 INFO - TEST-START | test_set_window_size.py TestSetWindowSize.test_that_we_throw_an_error_when_trying_to_set_maximum_size
11:50:35 INFO - TEST-PASS | test_set_window_size.py TestSetWindowSize.test_that_we_throw_an_error_when_trying_to_set_maximum_size | took 239ms
Assignee: mats → nobody
Not from Mats' push. Rob, maybe from bug 984508?
Flags: needinfo?(rwood)
(In reply to Ryan VanderMeulen [:RyanVM UTC-5] from comment #4)
> Not from Mats' push. Rob, maybe from bug 984508?

The failing test (test_set_window_size.py) passed fine on Ubuntu x64 on my patch's try [1], so I don't believe so...

[1] https://tbpl.mozilla.org/php/getParsedLog.php?id=53083161&tree=Try&full=1
Flags: needinfo?(rwood)
It's an *intermittent* failure, so one pass on your Try push doesn't rule you out ;)
(In reply to Ryan VanderMeulen [:RyanVM UTC-5] from comment #4)
> Not from Mats' push. Rob, maybe from bug 984508?

Looks like the manifest part of the patch in this bug inadvertently re-enabled this test on linux.
https://hg.mozilla.org/mozilla-central/rev/74edfbf0e6a3
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla36
Ugh, apologies - thanks for spotting and fixing my manifest mistake, appreciated.
Flags: needinfo?(rwood)
Assignee: nobody → rwood
Blocks: 984508
No longer blocks: 984508
These recent ones were a regression from bug 1141519, which has been backed out.
You need to log in before you can comment on or make changes to this bug.