TEST-UNEXPECTED-FAIL | /builds/slave/test/gaia/apps/system/test/marionette/rocketbar_activity_layout_test.js | Rocketbar - Opened Activity From Search has proper layout

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: mikehenrty, Assigned: mikehenrty)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [systemsfe])

Attachments

(1 attachment)

Failing on v2.1 only.
Created attachment 8527997 [details] [review]
[Gaia v2.1 PR] force hide keyboard

Looks like there is a bug in b2g-desktop where the keyboard does not automatically hide when long pressing a bookmark from the search app. Since this issue does not reproduce on the device or on b2g-desktop master, I think we can work around it here.
Comment on attachment 8527997 [details] [review]
[Gaia v2.1 PR] force hide keyboard

Still waiting for the tests to build, but this fixed the problem locally.

Kevin, mind having a look at this workaround? Feel free to ping me if you have questions.
Attachment #8527997 - Flags: review?(kgrandon)
Comment on attachment 8527997 [details] [review]
[Gaia v2.1 PR] force hide keyboard

\o/ fix all the tests!

I am fine with this approach. If it doesn't work, I guess we could probably just disable the test. Thanks for the patch.
Attachment #8527997 - Flags: review?(kgrandon) → review+
Yup, that fixed it.

master: https://github.com/mozilla-b2g/gaia/commit/3307ea5a579d3a695896b7a190e934e5a7b6129f
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.