If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Open Web Location dialog doesn't get focus

VERIFIED DUPLICATE of bug 108787

Status

()

Core
Keyboard: Navigation
VERIFIED DUPLICATE of bug 108787
16 years ago
16 years ago

People

(Reporter: Craig Emery, Assigned: Brian Ryner (not reading))

Tracking

({access, sec508})

Trunk
x86
Linux
access, sec508
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
When I use <CTRL><SHIFT> L to get the "Open Web Location" there is no keyboard
focus.

The last entry is hilighted but I cannot get keyboard focus to type anything
without actually clicking on any active widget. Then <TAB> will let me change
what the keyboard is focused on.

This is *very* annoying as I was keeping to the keyboard when using the keyboard
accelerator to open the dialog. Being keen to keep my hands on the keyboard,
this has stopped me from using nightly for a while.

This happens on the "Open or Save" dialog too.

It doesn't happen on 0.9.5 but has done so on the nightly (repeated with
200111521) for quite some time.

Updated

16 years ago
Summary: No keyboard forcus on dialogs → No keyboard focus on dialogs

Comment 1

16 years ago
Works for me, Craig, 0.9.5 and 2001111521. Some details might be useful here.
What window manager and focus strategy do you use? Did you try it with a fresh
profile?
Component: Browser-General → Keyboard Navigation
(Reporter)

Comment 2

16 years ago
I did this:

% cd ~/
% mv .mozilla .mozilla.RENAMED
$ /usr/local/mozilla-2001-11-15-21-trunk/mozilla

and the first time I hit <CTRL><SHIFT>L I could type into the (empty) text
field, no problem.

However, as soon as I had opened one new browser tab using this "strategy" then
subsequent times the last URL I've opened is prefilled in the URL text field,
it's hilighted but the widget has no keyboard focus.

I'm using Ximian GNOME + sawfish under RH 7.1 with click-to-focus and focus
granted to new windows and windows get focus even when they haven't asked for it
(these are all sawfish focus settings).

Comment 3

16 years ago
The wonders of detailed instructions!
It is true, I fail miserably, the popup window does not get focus. ---> NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

16 years ago
Diego, don't forget to "reassign bug to owner and QA contact" :) (i make that
mistake all the time).  

Reassigning.
Assignee: asa → aaronl
QA Contact: doronr → sairuh

Comment 5

16 years ago
*** Bug 110469 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
-> trudelle, for triage
Assignee: aaronl → trudelle
Keywords: access, fcc508
Summary: No keyboard focus on dialogs → Open Web Location dialog doesn't get focus

Comment 7

16 years ago
->bryner
Assignee: trudelle → bryner
*** Bug 111762 has been marked as a duplicate of this bug. ***
*** Bug 112059 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 10

16 years ago

*** This bug has been marked as a duplicate of 108787 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
okidoke, v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.