[B2G][Keyboard] Long-pressing Delete/Backspace button on keyboard causes it to disappear.

RESOLVED DUPLICATE of bug 1102135

Status

RESOLVED DUPLICATE of bug 1102135
4 years ago
4 years ago

People

(Reporter: ddixon, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

(Whiteboard: [systemsfe], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8528027 [details]
backspace_logcat

Description:
When user enters 5 characters in the Rocketbar keyboard, then long-presses the Backspace
button to the delete the text, the keyboard disappears from view. 

Repro Steps:
1) Update a Flame to 20141124051443
2) Connect to wifi or data
3) Tap on rocket bar and type at 1-10 characters
4) Long press Delete/Backspace on keyboard

Actual Results: 
Long-pressing Delete/Backspace on keyboard causes the keyboard to disappear. 

Expected Results: 
Long-pressing Delete/Backspace button rapidly deletes text. 

Environmental Variables:
Device: Flame 2.2 (319mb) KK Shallow Flash
Build ID: 20141124051443
Gaia: 3b4c64b5a05d106568dae3f88d38bdbb3d5bc29e
Gecko: b8240bb9ae4f
Version: 36.0a1 (2.2)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:36.0) Gecko/36.0 Firefox/36.0

Repro frequency: 8/10 100%

See attached: video clip, logcat

Video URL: 
http://youtu.be/RiHxil6Ihx8
(Reporter)

Comment 1

4 years ago
Branch Check

Issue DOES NOT occur in Flame 2.1, 2.0 (Shallow Flash, eng. build, 319 MB memory).

Actual Results: Keyboard functions correctly when user long presses backspace/delete key on rocketbar. 

Device: Flame 2.1
BuildID: 20141124092241
Gaia: 8ae086c39011bc8842b2a19bb5267906fa22345a
Gecko: 3d7442bb08ff
Version: 34.0 (2.1)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
----------------------------------------------
Device: Flame 2.0
BuildID: 20141124070841
Gaia: 2e3f4de97dfd776dc545ebd167eceb419ac2007b
Gecko: 3e842983c83c
Version: 32.0 (2.0)
Firmware: V188-1
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0M: --- → unaffected
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: unaffected → affected
Flags: needinfo?(dharris)
Not a great experience, adding regression information and nominating.
blocking-b2g: --- → 2.2?
Keywords: regression, regressionwindow-wanted
(Reporter)

Updated

4 years ago
QA Contact: ddixon
(Reporter)

Updated

4 years ago
status-b2g-v2.0: --- → unaffected
status-b2g-v2.0M: unaffected → ---
(Reporter)

Updated

4 years ago
Flags: needinfo?(jmercado)
This is a duplicate of bug 1102135.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
Resolution: --- → DUPLICATE
Duplicate of bug: 1102135
Flags: needinfo?(dharris) → needinfo?
blocking-b2g: 2.2? → ---
Flags: needinfo?
You need to log in before you can comment on or make changes to this bug.