can't script Flash through Javascript



Tech Evangelism Graveyard
English US
17 years ago
3 years ago


(Reporter: Daniele Dellafiore, Assigned: Arun Ranganathan)





(3 attachments)



17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.5+)
BuildID:    2001111411

Flash plugin start (5r41), but does not work properly. It does not show a part
of the screen with the buttons that is visible with IE + Flash5r42, so the page
is unusable.

Reproducible: Always
Steps to Reproduce:
1.Go to specified URL

Expected Results:  Show the complete Flash Plugin.

May be that the problem is that IE got r42 of Flahs, instead Netscape got only r41.
The problem occurs also with M0.9.5, N6.2 and several builds post 095.

Comment 1

17 years ago
yeah, I vote for r41 should be replaced with r42 in netscape distributions.

Comment 2

17 years ago
I'm on Win2K, Build 2001120504 and experience this problem too. I also get the
same thing with Acrobat and quicktime and WinMedia plugins: the plugin starts,
but no content is displayed. The Java plugin works.

I downloaded a Nov 27 build, and everything worked, but yesterday I got a daily,
and it hasn't worked since...

I was hoping this would be solved by that plugin registry refresh thing, but no
such luck.

Comment 3

17 years ago
confirming that buttons are not visible (win NT 20011205)
Ever confirmed: true

Comment 4

17 years ago
ok...I found something. I think the flash video just stops before finishing...

I say this because : if I right click on the left side just outside the orange 
border and select 'FORWARD', the buttons on the left side load. Same is true for 
the bottom portion of the flash video. 
The video appears conplete.  Daniele, can you confirm ?

Comment 5

17 years ago
*** Bug 113768 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
Yes, i can confirm.
There are three panel that appears (left, bottom and bottom-left) if I
select FORWARD, and if I select all of this the flash appear as in IE5.
If I Select a button, all the panel disappear and I have to repeate the
same operation.

Comment 7

17 years ago
I have the same behavior with Apple's QuickTime plugin (In addition to with the
Flash plugin)

Comment 8

17 years ago
Created attachment 62865 [details]
screen shot showing Flash having loaded, but not running.

I'm on mozilla build 2001122703, Win2k, Flash 5r42. The pop-up is from
right-clicking on the white area on the left where there is supposed to be a
Flash-driven menu.

Not really sure what the terrible formatting of the images is about...

Comment 9

16 years ago
*** Bug 118115 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
I do have flash 5.0 r41 installed,
but I have not found any flash content on
there are only several anim gif images:( has flash object on the left
I can see it properly in my 2002-01-14 w2k debug build.
Shrirang could you update the test case for this bug please?

Comment 11

16 years ago
serge, go to
click on "ISDN"
Observe the flash movie playing-> click on SKIP and see the actual video which 
loads partially.

Comment 12

16 years ago
sorry, the steps should have been mentioned clearly 

Comment 13

16 years ago
thanks, I can see it now.

Comment 14

16 years ago
I followed Shrirang's instructions in Comment #11 with no success:

I just get a big, blank, white square. No movie, no "skip" link. A right click
reveals a menu that says "Movie not loaded" which is greyed out, and "About
Macromedia Flash Player 5..."

I am on W2K, build 2002011703. I do have values set for my cache sizes, I saw
that mentioned in some of the duplicates, but to no avail.

Also, one person in a duplicate stated that Flash hasn't worked for him since 0.9.6

Comment 16

16 years ago
Hey Serge.

Yeah, I tried that with 2002011703, and it's the same as I reported before: all
flash content is replaced by empty boxes, and the popup on those areas show
"Movie not loaded".

I also installed 0.9.6 and tried it, and everything works great with that old
one (Build 2001112009). Lots of swishing graphics and other neat things.

So I don't know what changed between then and now, but with current builds, it's
now definitely broken on my system. And, as I've stated before, several other
plugins don't work either: Acrobat, and Quicktime (they *do* with 0.9.6).

Comment 17

16 years ago
Thanks Zac.
That is strange:( all plugins, you mentioned, work just fine for me with w2k 
latest mozilla bits. The problem with flash content on, 
as Srirang described it, could be a flash problem itself.
I'll try to make a simple test case for that.

Comment 18

16 years ago
I just wanted to add my $0.02 - 

There's another bug somewhere in bugzilla that details this -- but disabling
Mozilla's disk cache also disables the following plug-in(s):  Flash, QT,
Shockwave.  I'm sure there are others.

Which is kind of irksome, as I have plenty of memory to just use a memory cache.
 I sure hope that Mozilla checks the Memory cache before the disk cache (which
I'm sure it does).

Comment 19

16 years ago
Not sure what you mean by disabling the cache, but my caches are set to 4M
memory and 10M disk.

Also, I don't change any settings between 0.9.6 and the latest, and 0.9.6 works,
latest doesn't.

Comment 20

16 years ago
Release of flash used by mozilla is 5.0 r41, insted IE uses r42.
Can't the problem be this?

Comment 21

16 years ago
I'm seeing this (or a similiar bug) on Linux installs of 0.9.7 and build
20020113.1 - both the Crossover Quicktime plugin and the Flash load up fine, but
appear to have problems loading additional data (Quicktime shows a 'broken film'
icon, Flash displays a blank screen (with the right-click menu showing "Movie
not loaded").

No problems with Java; Galeon 1.0.2 using the 0.9.7 libraries works fine with
the plugins too.

Comment 22

16 years ago
In an effort to narrow down exactly what build this became broken for me, I was hunting through the 
builds in but it doesn't go far enough back 
(only about a month back). Is there a repository of nightly windows build from between 0.9.6 
(2001/11/20) and 2001/12/26?

Comment 23

16 years ago
I doubt it. 
Could you try to move mozilla's registry.dat file, on w2k you can find it most 
likely in %SystemDrive%:\Documents and Settings\<users_name>\Application 
Data\Mozilla directory, into %TEMP%?
I'm just guessing ...

Comment 24

16 years ago
Removing the registry didn't help, but trashing the ~/.mozilla directory
completely seems to have cured the problem on my Linux box.

Comment 25

16 years ago
Nice catch Dan!

I can verify that removing ~\Application Data\Mozilla\ on W2K also solves 
this problem on build 2002012403.

I will endeavour to see exactly what file in this 
directory is messing us up. But first, I must go snowboarding.

Comment 26

16 years ago
Under ~\Application Data\Mozilla\ on W2K Ihave only registry.dat (wich contains
infos about profiles) and a empty "profiles" directory. I have all my profiles
in another directory on another drive.

deleting registry.dat cause mozilla create a new profile in ~\Application
Data\Mozilla\ and start with default options, but the bug remains.

build 2002020409

Comment 27

16 years ago
Just in case, I am talking about

Comment 28

16 years ago
Ah, for me the profile and registry have the same base directory. 

Anyway, it seems that the 
bug disappears for me with a clean profile, removing the registry does not seem to make a 
difference. I tried keeping my old registry, and moved the Profile dir (on startup the profile 
"wizard" ran) and Flash works fine.

Comment 29

16 years ago
WFM on Windows XP. 

Daniele, what's your disk cache set to? Can you attach the output from
about:plugins to this bug. Thanks.

May have been fixed another bug (I see an align=top inside a nested embed).


Comment 30

16 years ago
Created attachment 68530 [details]

This is a screenshot of about:plugins focused on flash plugin.
I cannot attacch all page cause the save feature doesn't work for that page (!)
and  even if I send it to me, the attacch can'r be saved.

my disk cache is set to 50000 Kb (memory on 16000).

you can see that mozilla is installed on G:\Programmi\internet\Mozilla,
registry.dat is in 
G:\Documents and Settings\Daniele Dellafiore\Dati applicazioni\Mozilla
and my user directory is on e:\users\della. 

Running with a new clean profile doesn't solve the problem. 
(W2K SP2, Moz build 2002020409)

Comment 31

16 years ago
Created attachment 68532 [details]
screenshot of flash not running on

This is how the flash is showed to me after i have checked the "Riproduci" (run
or play in english) in the left pane of flash. The central pane has always
"Riproduci" checked, but in the other three is unchecked.
If I check that item on the each other panes, the flash run and is showed
correctly, but if I navigate throug it, the problem returns.

Comment 32

16 years ago
This is yet another evangelism bug because Macromedia has not released a
compatible Flash player for Mozilla that can accept Javascript commands. :(

The reason the other flash animations don't automatically play in the testcase
is because there is Javascript in that frame's onload handler that starts the
animation. The page can be changed to simply auto-load the Flash.

Many international sites script Flash so this is a comon problem. A quick way to
determine if a web page is showing this problem is to open the Javascript
console from the Tasks/Tools menu. Notice on the testcase that obj.GotoFrame is
not a function [on the Flash player]. 
Assignee: av → aruner
Component: Plug-ins → Plugins
Product: Browser → Tech Evangelism
QA Contact: shrir → mgalli
Summary: Flash plugin start (5r41), but does not work properly. → can't script Flash through Javascript
Version: other → unspecified

Comment 33

16 years ago
*** Bug 135098 has been marked as a duplicate of this bug. ***


16 years ago
Blocks: 139820

Comment 34

16 years ago
*** Bug 93523 has been marked as a duplicate of this bug. ***

Comment 35

16 years ago
*** Bug 88105 has been marked as a duplicate of this bug. ***

Comment 36

16 years ago
*** Bug 149293 has been marked as a duplicate of this bug. ***

Comment 37

16 years ago
seems like these dudes have changed the home page layout. with the latest 
scriptable flash player , I see the same content as on IE. close this? 

Comment 38

16 years ago
I'm under the impression that this is an Evangelism bug directed at Macromedia
and not the folks at and thus the reason for all the
dupes/dependancies... Perhaps new test cases are needed, but this bug is most
certainly not fixed

Comment 39

16 years ago
changing platform to ALL
OS: Windows 2000 → All
Hardware: PC → All

Comment 40

16 years ago
*** Bug 152589 has been marked as a duplicate of this bug. ***

Comment 41

16 years ago
*** Bug 152589 has been marked as a duplicate of this bug. ***

Comment 42

16 years ago
*** Bug 125208 has been marked as a duplicate of this bug. ***

Comment 43

16 years ago
This bug can almost be marked FIXED:

Macromedia is in the process of doing the required upgrades to Flash to enabled
scriptablity in Gecko. Netscape employees who would like to
help test a version of the Flash player that is Javascriptable, please see the
e-mail from Paul Wyskoczka ( sent to cpd-all on where to download.
Using that player, this bug should be able to be verified.

Comment 44

16 years ago
*** Bug 112684 has been marked as a duplicate of this bug. ***

Comment 45

16 years ago
*** Bug 156975 has been marked as a duplicate of this bug. ***

Comment 46

16 years ago
I'm marking this bug FIXED because Macromedia has released Flash 6r40 on Mac and
Windows which supports XPConnect and is Javascriptable:
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 47

16 years ago
*** Bug 135799 has been marked as a duplicate of this bug. ***

Comment 48

16 years ago
I got this from Fabricio Zuardi and confirmed also with Netscape 7PR and Flash 6R40:

And it's not working. I am reopenning this bug and asking for help to recheck if
this Simple Flash scriptable example hosted at Macromedia is supposed to work or
not. Works correctly with Netscape 4.x and IE. 

Additionally, it's important to note that the example is really pretty
inconsistent. In some machines you will see working (the first page) in some
other cases with the same Flash 6R40 you will see the blank menus. 
Resolution: FIXED → ---
Confirming, I tested on Mozilla 1.0 (Build ID:2002053012), with Flash plugin
Shockwave Flash 6.0 r40, Win2k.


Dont work.

Comment 51

16 years ago
tested on mozilla 1.1 beta, win2K.

Comment 52

16 years ago
As usual, PLEASE open NEW bugs on individual problems. The ford site works just
fine for me on WinXP and that other URL could be failing due to some incorrect
markup. As always, please try to attach a simplified testcase to the new bug
showing which combination of valid markup is failing.

Mozilla QA Flash scriptability verifiction tests:
...pass for me with today's Mozilla branch and trunk:
...after I copied both at the same time, npswf32.dll 6.0r40 and flashplayer.xpt
to my plugins folder, this URL works:
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Comment 53

16 years ago

Comment 54

16 years ago
Ok, I've unistalled my mozilla, reinstalled the 1.0 branch removed NPSWF32.dll
from  all Plugins directories of my computer, then I went to macromedia page and
downloaded the installer, so I installed it and the test pages didnt work.

Following comment #52 I made a search for the flashplayer.xpt file and there
were one in the components directory of my Netscape, so I copied that file to
the Plugins folder of my Mozilla and it finally worked.

So I am suspecting that Macromedia installer doesnt install the xpt file, I will
open a new bug about this...

Comment 56

16 years ago
I talked with Arun. We do have some problem with the fact that the macromedia
installer will not copy and xpt if you have too many browsers. THis is probably
only affecting developers they usually have many browsers. 

Comment 57

16 years ago
You can just click on the XPI package that comes with the browser:
I have filled bug 159393 about this xpt issue.

Comment 59

16 years ago
*** Bug 160072 has been marked as a duplicate of this bug. ***

Comment 60

15 years ago
SPAM: New Components
Component: Plugins → English US
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.