[WebAudioAPI] Oscillator waveform other than "sine" is distorted in low frequency.

RESOLVED FIXED

Status

()

Core
Web Audio
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: gaito, Unassigned)

Tracking

36 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.65 Safari/537.36

Steps to reproduce:

1. access to http://bit.ly/1xwmlmo
2. press "Play" button


Actual results:

Oscillator sounds but the frequency almost remains 1000Hz.


Expected results:

1Hz "square" oscillator connect to second osc's frequency AudioParam.
It should sounds alternating 500Hz and 1500Hz .
(Reporter)

Updated

4 years ago
Component: Untriaged → Web Audio
Product: Firefox → Core
(Reporter)

Comment 1

4 years ago
The link is a bit wrong but almost same case.
Correct link is here : http://bit.ly/1xwmQgf

Updated

4 years ago
The link still doesn't work. Please correct

Comment 3

4 years ago
It works for me, another one: http://goo.gl/fsGNqz
(In reply to gaito from comment #0)
> Actual results:
> Oscillator sounds but the frequency almost remains 1000Hz.
How can this be checked ? I can't tell by simply listening.
(Reporter)

Comment 5

4 years ago
It is okay if it sounds alternate high-tone(1500Hz) and low-tone(500Hz).
But the actual results are not alternating high/low tone.

This is just a problem of waveform in low frequency.
My friend has checked the oscillator waveform:
https://qiita-image-store.s3.amazonaws.com/0/2568/8b1355ec-3c8a-6bbd-4591-15b464bc55c3.png

in frequency=1Hz, the square wave is not square.

I think this is a adverse effect of DC rejection filter.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Don't bother checking anything here, I'm completely changing the way this works in bug 1106649.
Depends on: 1106649
Fixed by bug 1106649.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.