[gonk-l] toolkit/mozapps/update/updater get compile error

RESOLVED FIXED in 2.2 S4 (23jan)

Status

defect
--
major
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: seinlin, Assigned: seinlin)

Tracking

unspecified
2.2 S4 (23jan)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

Assignee

Description

5 years ago
No description provided.
Kai-Zhen, do you want to take this bug?
Flags: needinfo?(kli)
Assignee

Updated

5 years ago
Assignee: nobody → kli
Flags: needinfo?(kli)
Assignee

Comment 2

5 years ago
Posted patch bug-1104655-updater.patch (obsolete) — Splinter Review
Michael, Could you review this patch? As without this patch there is a compile error.
--
gecko/toolkit/mozapps/update/updater/updater.cpp:2392: error: undefined reference to 'ioprio_set'
collect2: error: ld returned 1 exit status
make[3]: *** [updater] Error 1
Attachment #8539642 - Flags: review?(mwu)
Assignee

Comment 3

5 years ago
Why I got this compile error is because I have 'export B2G_UPDATER=1' in .userconfig.
blocking-b2g: --- → 2.2?

Comment 4

5 years ago
Comment on attachment 8539642 [details] [diff] [review]
bug-1104655-updater.patch

Review of attachment 8539642 [details] [diff] [review]:
-----------------------------------------------------------------

Can you implement ioprio_set using syscall instead?
Attachment #8539642 - Flags: review?(mwu)

Comment 5

5 years ago
Request review from rstrong when you have a new patch.
Assignee

Comment 6

5 years ago
Posted patch bug-1104655.patch (obsolete) — Splinter Review
Michael, I use syscall to set ioprio in this path. But ICS do not have the definition of SYS_ioprio_set so I add a checking for it. Could you review this patch? Thanks!
Attachment #8539642 - Attachment is obsolete: true
Assignee

Updated

5 years ago
Attachment #8545613 - Flags: review?(mwu)

Comment 8

5 years ago
Comment on attachment 8545613 [details] [diff] [review]
bug-1104655.patch

Review of attachment 8545613 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/mozapps/update/updater/updater.cpp
@@ +2388,5 @@
>        if (setpriority(PRIO_PROCESS, 0, prioVal)) {
>          LOG(("setpriority(%d) failed, errno = %d", prioVal, errno));
>        }
> +      if (syscall(SYS_ioprio_set, IOPRIO_WHO_PROCESS, 0,
> +                  IOPRIO_PRIO_VALUE(ioprioClass, ioprioLevel))) {

Implement ioprio_set - don't replace it with syscall. And also ask rstrong for review.
Attachment #8545613 - Flags: review?(mwu)
Assignee

Comment 9

5 years ago
Hi Robert, Because ioprio_set is not available in gonk-l, we need to use syscall implement it. Could you review this patch? Thanks!
Attachment #8545613 - Attachment is obsolete: true
Attachment #8547144 - Flags: review?(robert.strong.bugs)
Assignee

Comment 10

5 years ago
BTW, Remove the extern one and always use local implement also work.
Attachment #8547144 - Flags: review?(robert.strong.bugs) → review+
(In reply to Kai-Zhen Li [:seinlin] from comment #10)
> BTW, Remove the extern one and always use local implement also work.

That's what I had in mind, but this is ok too.
Assignee

Comment 13

5 years ago
Comment on attachment 8547144 [details] [diff] [review]
bug-1104655_v2.patch

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): porting job.
User impact if declined: update service may fail.
Testing completed: local test and land in m-c.
Risk to taking this patch (and alternatives if risky): low, add a local implementation for missing function call.
String or UUID changes made by this patch: none
Attachment #8547144 - Flags: approval-mozilla-b2g37?
https://hg.mozilla.org/mozilla-central/rev/692637471b98
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
blocking-b2g: 2.2? → 2.2+
Attachment #8547144 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
You need to log in before you can comment on or make changes to this bug.