Closed Bug 1104835 Opened 6 years ago Closed 6 years ago

Port bug 1101170 (Move Linux desktop sandboxing code into plugin-container) to fix bustage: Missing file(s): bin/libmozsandbox.so

Categories

(Thunderbird :: Build Config, defect)

x86_64
Linux
defect
Not set
blocker

Tracking

(thunderbird36 fixed)

RESOLVED FIXED
Thunderbird 36.0
Tracking Status
thunderbird36 --- fixed

People

(Reporter: aryx, Assigned: clokep)

References

Details

Attachments

(1 file)

Error: /builds/slave/tb-c-cen-lx-000000000000000000/build/objdir-tb/mail/installer/package-manifest:558: Missing file(s): bin/libmozsandbox.so
Traceback (most recent call last):
  File "/builds/slave/tb-c-cen-lx-000000000000000000/build/mozilla/toolkit/mozapps/installer/packager.py", line 402, in <module>
    main()
  File "/builds/slave/tb-c-cen-lx-000000000000000000/build/mozilla/toolkit/mozapps/installer/packager.py", line 353, in main
    copier.add(mozpack.path.join(respath, 'removed-files'), removals)
  File "/tools/python27/lib/python2.7/contextlib.py", line 24, in __exit__
    self.gen.next()
  File "/builds/slave/tb-c-cen-lx-000000000000000000/build/mozilla/python/mozbuild/mozpack/errors.py", line 129, in accumulate
    raise AccumulatedErrors()
mozpack.errors.AccumulatedErrors
make[3]: *** [stage-package] Error 1
make[3]: Leaving directory `/builds/slave/tb-c-cen-lx-000000000000000000/build/objdir-tb/mail/installer'
make[2]: *** [make-package] Error 2
make[2]: Leaving directory `/builds/slave/tb-c-cen-lx-000000000000000000/build/objdir-tb/mail/installer'
make[1]: *** [default] Error 2
make[1]: Leaving directory `/builds/slave/tb-c-cen-lx-000000000000000000/build/objdir-tb/mail/installer'
make: *** [package] Error 2
State Changed: unlock buildroot
program finished with exit code 2
Severity: normal → blocker
OS: Windows 8.1 → Linux
Blocks: 1101170
Attached patch Trivial portSplinter Review
Assignee: nobody → clokep
Status: NEW → ASSIGNED
Attachment #8528472 - Flags: review?(Pidgeot18)
Attachment #8528472 - Flags: review?(Pidgeot18) → review+
https://hg.mozilla.org/comm-central/rev/7608f6d191c9
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 36.0
Duplicate of this bug: 1104690
You need to log in before you can comment on or make changes to this bug.