Update Yahoo! Search Plugin for en-US

RESOLVED FIXED in Firefox 34

Status

()

P1
critical
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: kev, Assigned: kev)

Tracking

34 Branch
Firefox 37
Points:
---

Firefox Tracking Flags

(firefox34+ verified, firefox35+ fixed, firefox36+ fixed, firefox37 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Created attachment 8528521 [details] [diff] [review]
Update Yahoo! for en-US

As part of the transition to Yahoo as default search, some attributes need to be modified for the en-US plugin (only). Note that the FR code will no longer be used, and the updated parameters are in the patch. The search suggests URL will remain unchanged.
Attachment #8528521 - Flags: review?(gavin.sharp)
Attachment #8528521 - Flags: feedback?(mconnor)
Duplicate of this bug: 1104218
status-firefox34: --- → affected
status-firefox35: --- → affected
status-firefox36: --- → affected
tracking-firefox34: --- → +
tracking-firefox35: --- → +
tracking-firefox36: --- → +
Attachment #8528521 - Flags: review?(gavin.sharp) → review+
Comment on attachment 8528521 [details] [diff] [review]
Update Yahoo! for en-US

Looks good to me.
Attachment #8528521 - Flags: feedback?(mconnor) → feedback+
Attachment #8528521 - Flags: approval-mozilla-release+
Attachment #8528521 - Flags: approval-mozilla-beta+
Yahoo searches are redirected to https://search.yahoo.com/yhs/search?p= when searching from url bar, about:home, about:newtab and search toolbar.

Firefox 34.0 build 2
Environments: Win 7 64-bit, Ubuntu 12.04 32-bit and Mac OSX 10.9.5
status-firefox34: fixed → verified
QA Contact: petruta.rasa
(Assignee)

Comment 7

4 years ago
If you're outside the US, this is the expected result. There will be an override pushed in the coming days to the results page, but unless you're in the US at this time, geo-located redirects will occur.
Try: https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=b232181e8006

https://hg.mozilla.org/mozilla-central/rev/a7af8edcf64b
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-firefox37: --- → fixed
Resolution: --- → FIXED
Target Milestone: Firefox 34 → Firefox 37
You need to log in before you can comment on or make changes to this bug.